Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sverweis 2Vertikale Bedingungen 1 Horizontale Bedi

Sverweis 2Vertikale Bedingungen 1 Horizontale Bedi
14.01.2013 14:33:36
Raphael
Hallo Zusammen,
ich bae ein Problem und ich hoffe ihr könnt mir weiterhelfen:
Ich habe einen Kalender:
Vertikal: A2:A32 = Datum (1-31) ; B2:B32 = Mitarbeiter Name; und die Monatsnamen (C1:N1).
Jetzt möchte ich nach dem 15 Tag eines Monats suchen (A2:A32), ebenso nach dem Mitarbeiter Namen(B2:B32), sowie nach dem Monat März (C1:N1). und wenn alle 3 Bedingungen stimmen, soll mir der Wert aus der MATRIX C2:N32 ausgegeben werden:
Ich habe hier mal eine formel:
=INDEX(C2:M32;VERGLEICH(Q4;A2:A32;0);VERGLEICH(Q5;B2:B32;0);VERGLEICH(Q3;C1:N1;0))
Aber da bekomme ich nichts raus!
Hier noch das File
https://www.herber.de/bbs/user/83386.xls
könnt ihr mit helfen?
Besten dank
Raphael

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sverweis 2Vertikale Bedingungen 1 Horizontale Bedi
14.01.2013 14:46:02
Klaus
Hi,
die Formel für Q6:
=IF(VLOOKUP(Q4;A:B;2;)=Q5;INDEX(A1:N32;MATCH(Q4;A:A;);MATCH(Q3;1:1;));"nix gefunden")
müsste auf deutsch sein:
=wenn(sverweis(q3;A:B;2;)=q5;index(A1:N32;vergleich(q4;A:A;);vergleich(Q3;1:!;));"nix gefunden")
Grüße,
Klaus M.vdT.

2 kleine Schreibfehler
14.01.2013 16:01:19
KlausF
Hallo Klaus,
haben sich noch 2 kleine Schreibfehler eingeschlichen:
=WENN(SVERWEIS(Q4;A:B;2;)=Q5;INDEX(A1:N32;VERGLEICH(Q4;A:A;);VERGLEICH(Q3;1:1;)); "nix gefunden")
Ansonsten: Super Formel
Gruß
auch Klaus

DANKE!
14.01.2013 16:34:38
Raphael
Danke das ist echt ne gute Formel!
genau das habe ich gesucht! Danke und noch eine schöne Restwoche!

Anzeige
Danke für die Rückmeldung! mT
15.01.2013 08:24:46
Klaus
Hi,
danke für die Rückmeldung, und KlausF: Danke für die Korrekturen.
Das ist das Kreuz mit den mehrsprachigen Formeln, grad wenn man die längeren ohne Syntaxhilfe übersetzt und abtippt passiert sowas leider. Darum poste ich auch immer mit "Copy und Paste" die englische Formel dazu.
Grüße,
Klaus M.vdT.
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige