Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweis Excel 2010 NV falsche bezüge

Betrifft: SVerweis Excel 2010 NV falsche bezüge von: Markus Janke
Geschrieben am: 12.03.2013 12:09:46

Hallo zusammen,

ich hoffe mir kann jemand helfen.
Ich habe eine Exceldokument mit 3 Reitern. Im dritten Reiter befinden sich die Rohdaten, aus denen ich Werte mit dem SVerweis ziehen möchte.
Dieses ist die Formel: =WENN(ISTNV(SVERWEIS(A12;Tabelle1!$A$1:$E$60;3));0;SVERWEIS(A12;Tabelle1!$A$1:$E$60;3))

Diese funktioniert in den Zeilen, mit den Werten die es tatsächlich gibt einwandfrei. Wenn jedoch nach einem Wert gesucht wird, der nicht in der Tabelle vorhanden ist, wird ein anderer Wert, der in einer anderen Zeile existiert angezogen. Es wird weder ein NV angezeigt noch die in der Formel erzwungene Null bei NV. Auch nicht wenn ich den reinen SVERWEIS verwende.

Besten Dank im voraus

  

Betrifft: AW: SVerweis Excel 2010 NV falsche bezüge von: Klaus M.vdT.
Geschrieben am: 12.03.2013 12:14:50

Hi,

falsche Formel:
=WENN(ISTNV(SVERWEIS(A12;Tabelle1!$A$1:$E$60;3));0;SVERWEIS(A12;Tabelle1!$A$1:$E$60;3))

richtige Formel:
=WENN(ISTNV(SVERWEIS(A12;Tabelle1!$A$1:$E$60;3;));0;SVERWEIS(A12;Tabelle1!$A$1:$E$60;3;))

noch bessere Formel ab Excel 2007:
=WENNFEHLER(SVERWEIS(A12;Tabelle1!$A$1:$E$60;3;);0)

Lesetip:
http://www.online-excel.de/excel/singsel.php?f=9

Grüße,
Klaus M.vdT.


  

Betrifft: Erklärung von: Klaus M.vdT.
Geschrieben am: 12.03.2013 12:16:01

Sorry, hab zu schnell auf "absenden" gedrückt:

Beachte in der "richtigen" Formel das Semikolon. Das setzte den BEREICH_VERWEIS des SVERWEIS auf FALSCH. Nähere Erklärungen: Excel-Hilfe, obriger Link zu Peter Haserodt.

Grüße,
Klaus M.vdT.


  

Betrifft: AW: SVerweis Excel 2010 NV falsche bezüge von: firmus
Geschrieben am: 12.03.2013 12:16:13

Hallo Markus,

hier ein Beispiel unter XLS2010engl., das funktioniert.
=IF(ISNA(VLOOKUP(B$1&"_"&$A8&"_CPC";CPU_per_Monat;6;FALSE));"";VLOOKUP(B$1&"_"&$A8&"_CPC"; CPU_per_Monat;6;FALSE))

NV wurde zu NA - so meine Erfahrung.

1. Suchbegriff wurd aus B1 + A8 zusammengesetzt.
2. Die Lookup-tabelle wird durch einen Namen angesprochen.
3. Ohne Namen, mit Zellen funktioniert auch.

Gruss,
Firmus


  

Betrifft: Nee, exakt US/Engl #NV => #N/A (not available) orT von: Luc:-?
Geschrieben am: 12.03.2013 13:07:21

Gruß Luc :-?


  

Betrifft: AW: SVerweis Excel 2010 NV falsche bezüge von: Markus Janke
Geschrieben am: 12.03.2013 14:11:10

Ich danke für die schnelle Hilfe,
beide Tipps haben mir weitergeholfen.

Gruss Markus


  

Betrifft: Danke für die Rückmeldung! owT. von: Klaus M.vdT.
Geschrieben am: 12.03.2013 15:46:55

.


 

Beiträge aus den Excel-Beispielen zum Thema "SVerweis Excel 2010 NV falsche bezüge"