Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1300to1304
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn-Dann-Formel mit 0 und Leerzellen

Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 10:18:57
MikeM
Hallo zusammen,
ich brauche mal wieder eine zündende Idee.
Ich habe eine Wenn-Dann-Formel:
=wenn(und(A1=0;B1=0;C1=0);"x";"")
So, wenn nun aber in A1,B1,C1 ein Leerzeichen ist, verhält es sich so als wäre eine 0 drin. Aber genau das möchte ich eigentlich nicht.
0 und Leerzelle sind werden hier gleich gewertet. Genau das möchte ich nicht.
Also wenn oben genannte Formel (also wirklich 3x die 0 vorkommt) eintritt, dann soll ein x stehen. Wenn aber 3x eine Leerzelle vorkommt, dann kein x.
Vielen Dank schon mal!
Grüße

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 10:23:23
Hajo_Zi
Tabelle1 (2)
 CD
1  x
24 

verwendete Formeln
Zelle Formel Bereich
D1 {=WENN(SUMME(WECHSELN(A1:C1;" ";""))=0;"x";"")} $D$1
C2 =LÄNGE(C1) 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


Tabellendarstellung in Foren Version 6.01



Anzeige
AW: Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 10:26:59
hary
Moin Mike
Sollte passen.
=WENN(ZÄHLENWENN(A1:C1;0)=3;"x";"")
gruss hary

AW: Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 10:27:45
Daniel
Hi
probiers mal so, Anzahl zählt die Zahlen im angegebenen Zellbereich.
=wenn(und(A1=0;B1=0;C1=0;Anzahl(A1:C1)=3);"x";"")
oder so:
=Wenn(Zählenwenn(A1:C1;0)=3;"x";"")
gruß Daniel

AW: Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 10:27:58
Uwe
Hallo Mike,
einfach abfragen:
=WENN(UND(A1=0;B1=0;C1=0;ISTZAHL(A1);ISTZAHL(B1);ISTZAHL(C1));"x";"")
Aber vielleicht geht es auch eleganter?
Gruß
Uwe
(:o)

So geht's auch, ...
14.03.2013 11:12:29
Luc:-?
…Mike:
=INDEX({""."x"};SUMMENPRODUKT((""&G7:I7="0")/3)+1)
…aber es geht/gibt über das bisher Gezeigte hinaus noch mehr, zB (mit) WAHL u.a.
Hättest du keine Zellbezüge, sondern Datenfelder (zB aus in derselben Fml berechneten Ausdrücken), könntest du ZÄHLENWENN nicht verwenden.
Gruß Luc :-?

Anzeige
AW: Wenn-Dann-Formel mit 0 und Leerzellen
14.03.2013 21:14:36
MikeM
Hey!
Vielen vielen Dank für die Antworten. Funktionieren so ziemlich alle.
Ich habe mich nun für eine für mich plausible (und gut nachvollziehbare) Formel aus den Angeboten entschieden.
Wie immer hier im Forum - Daumenhoch.
Danke + Grüße

453 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige