Microsoft Excel

Herbers Excel/VBA-Archiv

Zellwert + 1, aber nicht ...

Betrifft: Zellwert + 1, aber nicht ... von: Edwin
Geschrieben am: 28.06.2013 09:08:12

Hallo Leute,

in der Zelle A1 steht die Zahl 1.
in der Zelle B2 steht die Zahl 15,6.

Die Zellen A2:A20 enthalten fortlaufend folgende Formeln:
z.B. in A2
WENN(A1+1<$B$1;A1+1;"")
in A3
WENN(A2+1<$B$1;A2+1;"")
usw.

Das Ergebnis ist dann
A2 = 2
A3 = 3
...
A15 = 15
A16 = leer
A17 = leer
...

Soweit so gut, aber ich hätte gern, dass A16 nicht leer ist, sondern 15,6 steht.

Hat jemand eine Idee?

LG
Edwin

  

Betrifft: AW: Zellwert + 1, aber nicht ... von: Hajo_Zi
Geschrieben am: 28.06.2013 09:13:19

Hallo Edwin,

=B2

GrußformelHomepage


  

Betrifft: AW: Zellwert + 1, aber nicht ... von: UweD
Geschrieben am: 28.06.2013 09:38:35

Hallo


so?



Tabelle1

 AB
1115,6
22 
33 
44 
55 
66 
77 
88 
99 
1010 
1111 
1212 
1313 
1414 
1515 
1615,6 
1715,6 
1815,6 
1915,6 

Tabellendarstellung in Foren Version 5.49



Gruß UweD


  

Betrifft: in A2=WENN(A1+1<$B$1;A1+1;$B$1) von: UweD
Geschrieben am: 28.06.2013 09:42:04




  

Betrifft: AW: in A2=WENN(A1+1<$B$1;A1+1;$B$1) von: Edwin
Geschrieben am: 28.06.2013 11:35:07

Hallo UweD,

mit der komplizierten Verschachtelung
=WENN(A16="";"";WENN(A16+0,1>$B$1;""; WENN(A16+1<$B$1;A16+1;$B$1)))
habe ich das Problem gelöst.

Vielen Dank

LG
Edwin


  

Betrifft: AW: Zellwert + 1, aber nicht ... von: Klaus M.vdT.
Geschrieben am: 28.06.2013 09:37:09

Hi,

du hast das nicht getestet, oder? Mit deinem Beispiel ergibt A17 nicht "leer", sondern #WERT!.

mit Fehler-abfangen ab A2 so:

=WENN(A1="";"";WENN(A1+1<$B$2;A1+1;WENN(A1=$B$2;"";$B$2)))
Grüße,
Klaus M.vdT.


 

Beiträge aus den Excel-Beispielen zum Thema "Zellwert + 1, aber nicht ..."