Microsoft Excel

Herbers Excel/VBA-Archiv

Summieren, wenn X bei der Liste steht

Betrifft: Summieren, wenn X bei der Liste steht von: WalterK
Geschrieben am: 28.06.2013 11:23:56

Hallo,

ich suche eine Formellösung für folgende Summierung:

in Spalte A stehen ab der 10. Zeile Begriffe und dazu in den Spalten B bis E Werte.

in Spalte K ist eine Liste mit noch mehr Begriffen und daneben steht ein X wenn der Begriff für mich interessant ist.

Jetzt soll jeweils in B:E eine Summe von den Begriffen gemacht werden, bei denen ich in der K-Liste ein X daneben gemacht habe.

Beispieltabelle:
https://www.herber.de/bbs/user/86107.xls

Besten Dank für die Hilfe und Servus, Walter

  

Betrifft: AW: Summieren, wenn X bei der Liste steht von: Rudi Maintaire
Geschrieben am: 28.06.2013 11:38:16

Hallo,
darf's ne Hilfsspalte sein?

ABCDEF
9Summe unten89220 
10Zitrone5 170
11Apfel26280
12Birne 45 x
13Gurke586 0
14Mais8 8 x
15Kartoffel 59 x

ZelleFormel
B9=SUMMEWENN($F$10:$F$15;"x";B10:B15)
F10=SVERWEIS(A10;$K$2:$L$10;2;)


Gruß
Rudi


  

Betrifft: AW: Summieren, wenn X bei der Liste steht von: WalterK
Geschrieben am: 28.06.2013 12:24:31

Hallo Rudi,

sorry, hatte ich vergessen, es soll ohne Hilfsspalte funktionieren.

besten Dank und Servus, Walter


  

Betrifft: AW: Summieren, wenn X bei der Liste steht von: JACKD
Geschrieben am: 28.06.2013 11:45:24

Ohne Hilfspalte

=WENNFEHLER(WENN(L2="X";SUMME(INDEX($B$10:$E$15;VERGLEICH(K2;$A$10:$A$15;FALSCH);));"");"")
Grüße


  

Betrifft: AW: Summieren, wenn X bei der Liste steht von: WalterK
Geschrieben am: 28.06.2013 12:26:54

Hallo,

die Formel funktioniert bei mir aber nicht.

Besten Dank und Servus, Walter


  

Betrifft: Ist auch komplett falsch=) von: JACKD
Geschrieben am: 28.06.2013 12:28:52

Hallo Walter ..

Meine Summe ist ungeachtet der Tatsache das sie unter 2003 nicht funktionier (Da "wennfehler" )
AUch noch falsch Ich hab nicht die Spalten summiert, sondern die Zeilen (also nur die Früchte, wenn sie angekreuzt sind)

Grüße


  

Betrifft: vielleicht gibts ja noch ne Lösung .... von: WalterK
Geschrieben am: 28.06.2013 12:43:05




  

Betrifft: ICh grübel schon von: JACKD
Geschrieben am: 28.06.2013 12:46:35

aber ist nicht so einfach..

spricht was gegen eine UDF?

Grüße


  

Betrifft: Kann ich nicht .... von: WalterK
Geschrieben am: 28.06.2013 12:57:00

Hallo,

... sagen, hatte mit UDFs noch nichts zu tun.

Es sind 12 Monate (also Spalten) die so aufsummiert werden und sich bei jeder Änderung bei den X-en neu berechnen müssen.

Danke und Servus, Walter


  

Betrifft: Die Formel lautet ... von: Luc:-?
Geschrieben am: 28.06.2013 13:31:23

=SUMMENPRODUKT(ISTZAHL(VERGLEICH($A10:$A15&"x";$K2:$K10&$L2:$L10;0))*B10:B15)
Walter!
Gruß Luc :-?


  

Betrifft: Passt! Besten Dank Luc! Servus, Walter von: WalterK
Geschrieben am: 28.06.2013 13:34:42




  

Betrifft: Bitte sehr, gern geschehen! ;-) owT von: Luc:-?
Geschrieben am: 28.06.2013 13:43:27

:-?


  

Betrifft: Luc, von: JACKD
Geschrieben am: 28.06.2013 13:44:13

ich bin begeistert...

So ähnlich war meine Idee auch, habs nur nicht verformelt bekommen =)

Grüße


  

Betrifft: Na, dann ist ja noch Hoffnung... ;-] Gruß owT von: Luc:-?
Geschrieben am: 28.06.2013 13:51:42

:-?


  

Betrifft: AW: Na, dann ist ja noch Hoffnung von: hary
Geschrieben am: 28.06.2013 13:54:45

Moin Luc
Danke, schoen geloest. Und das ohne Abkuerzungen. Liest sich ganz leicht. ;-))
gruss hary


  

Betrifft: ...Für die war kein Platz...! ;-) Gruß owT von: Luc:-?
Geschrieben am: 28.06.2013 14:12:51

:-?


  

Betrifft: Falls du eine Mineralienliste ... von: Luc:-?
Geschrieben am: 28.06.2013 14:32:28

…hättest, Werner,
in der zB auch Onyx vorkäme, wäre natürlich Folgendes besser:
=SUMMENPRODUKT(ISTZAHL(VERGLEICH($A10:$A15&" x";$K2:$K10&" "&$L2:$L10;0))*B10:B15)
Oder du würdest X oder etwas ganz Eindeutiges zum Signieren verwenden.
Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Summieren, wenn X bei der Liste steht"