Microsoft Excel

Herbers Excel/VBA-Archiv

Straße & Hausnummer auswerten

Betrifft: Straße & Hausnummer auswerten von: Herbert
Geschrieben am: 02.07.2013 16:00:44

Hallo,

ich möchte in einer Auswertung die Straßen und Hausnummern auflisten.

In Spalte A stehen geordnet die Straßen. Dahinter in Spalte B die jeweilige Hausnummer.

Ich möchte gern, eine Übersicht "Straße / Hausnummer Beginn / Hausnummer Ende".

Es soll also nur einmal die Straße und die Erste sowie Letzte Nummer erscheinen.

Leider habe ich keine Lösung. Ihr vielleicht?

Bin über jede Hilfe dankbar.

Viele Grüße

  

Betrifft: AW: Straße & Hausnummer auswerten von: Klaus M.vdT.
Geschrieben am: 02.07.2013 16:05:14

Hi Herbert,

gibt uns doch mal ein paar dutzend Strassen + Hausnummern als Mustertabelle.

Grüße,
Klaus M.vdT.


  

Betrifft: AW: Straße & Hausnummer auswerten von: UweD
Geschrieben am: 02.07.2013 16:29:37

Hallo

das ginge so...

Probleme bei Hausnummern mit Zeichen...

also 14a, 16 Hinterhaus, 22 - 50 usw

Tabelle1

 ABCDEFG
1Der Weg40    Strasse vonbis
2Im Hasengarten18    Der Weg1260
3Im Hasengarten14    Im Hasengarten1418
4An der Autobahn22    An der Autobahn1122
5Hier5    Hier55
6Der Weg58    Dort88
7Im Hasengarten16         
8An der Autobahn11         
9Der Weg60         
10Dort8         
11Der Weg12         

verwendete Formeln
Zelle Formel Bereich
F2 {=MIN(WENN($A$1:$A$100=$E2;$B$1:$B$100))} $F$2
G2 {=MAX(WENN($A$1:$A$100=$E2;$B$1:$B$100))} $G$2
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


Tabellendarstellung in Foren Version 5.49




Gruß UweD


  

Betrifft: Mit der ein oder anderen Kleinen Formel von: JACKD
Geschrieben am: 02.07.2013 16:19:53

Hallo Herbert

so könnte es klappen =)

Spalte E erstellt eine Duplikatfreie Liste
Spalte F gibt das min der in E genannten Strasse
Spalte G das max

Grüße




Tabelle1

 ABCDEFGH
1Weg1    Weg17 
2Weg4    Strasse29 
3Weg7           
4Weg2           
5Strasse9           
6Strasse2           
7               
8               
9               

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
E1:E7{=WENNFEHLER(INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100) ) ;A$1:A$100) =1;ZEILE($1:$100) ) ;ZEILE(A1) ) ) ;"") }$E$1 =IFERROR(INDIRECT("A"&SMALL(IF(COUNTIF(OFFSET(R1C[-4],,,ROW(R1:R100) ) ,R1C[-4]:R100C[-4]) =1,ROW(R1:R100) ) ,ROW(RC[-4]) ) ) ,"")
F1:F8{=WENN(E1="";"";(MIN(WENN((A:A=E1) ;(B:B) ) ) ) ) }$F$1 =IF(RC[-1]="","",(MIN(IF((C[-5]=RC[-1]) ,(C[-4]) ) ) ) )
G1:G8{=WENN(E1="";"";MAX(WENN((A:A=E1) ;(B:B) ) ) ) }$G$1 =IF(RC[-2]="","",MAX(IF((C[-6]=RC[-2]) ,(C[-5]) ) ) )
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


XHTML Tabelle für Darstellung in Foren,
einschl. Bedingter Formatierung ab Version 2007
XHTML-Version 11.26





  

Betrifft: AW: Straße & Hausnummer auswerten von: Herbert
Geschrieben am: 02.07.2013 16:30:04

Super, vielen Dank. Funktioniert.


  

Betrifft: da hast Du Glück, denn ... von: neopa
Geschrieben am: 02.07.2013 18:18:24

Hallo Herbert,

... sehr häufig sind die Hausnummern keine reine Zahlenwerte. Es gibt da sehr viele andere Arten von Hausnummern, wie z.B. IVb oder 17a oder ...

@Jack,

Deine Formel zur Ermittlung der Straßennamen gefällt mir ob Ihrer Kürze. Wenn Du darin INDIREKT() noch durch INDEX() ersetzt wird sie noch kürzer und vor allem fällt eine der beiden volatilen Funktionen weg und die Formel wird dadurch auch nicht so anfällig gegen Tabellenänderungen. Ich habe bisher anstelle BEREICH.VERSCHIEBEN() immer eine Formel auf Basis von VERGLEICH() eingesetzt. Diese erfordert jedoch, um sie noch etwas kurzer zu halten eine Leerzelle in A1.
Also in E2 so z.B.: {=INDEX(A:A;MIN(WENN((VERGLEICH(""&A$2:A$99;""&A$2:A$99;))*ISTNV(VERGLEICH(A$2:A$99;E$1:E1;))*(A$2:A$99<>"");ZEILE(A$2:A$99))))}


Gruß Werner
.. , - ...

Jeder Interessent ist willkommen beim Exceltreffen 11.-13.10.2013 in Duisburg
Mehr dazu, siehe http://www.exceltreffen.de/index.php?page=230


 

Beiträge aus den Excel-Beispielen zum Thema "Straße & Hausnummer auswerten"