Elemente einer Datumsreihe



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Elemente einer Datumsreihe
von: Calin
Geschrieben am: 10.07.2002 - 12:14:21

Hallo

ich habe eine Spalte mit dem Tagesdatum (tt.mm.jjjj), in der zu jedem Tag beliebig viele Einträge sein können. Bsp.:
01.01.2002
02.01.2002
03.01.2002
03.01.2002
In einer Summenzelle darunter möchte ich die Anzahl der verschiedenen Tage haben, ohne Duplikate. Sowas wie ein "select distinct from tagesdatum" bei SQL. Im obigen Bsp. also '3'.
Was muss in der Summenzelle stehen?

Danke und Gruß,
Calin

nach oben   nach unten

Re: Elemente einer Datumsreihe
von: Andreas
Geschrieben am: 10.07.2002 - 12:36:07

Hallo Calin,

das geht so:
ohne Leerzellen:
{=SUMME(1/ZÄHLENWENN($A$1:$A100;$A$1:$A100))}

mit Leerzellen:
{=SUMME(WENN(A1:A100="";0;1/ZÄHLENWENN(A1:A100;A1:A100)))}

Schau Dir dazu unter http://www.excelformeln.de die Formel 42, 43 und 44 an!

Viel Spaß,
Andreas

nach oben   nach unten

Re: Elemente einer Datumsreihe
von: Heinz
Geschrieben am: 10.07.2002 - 12:41:17

Hallp Calin,

In eine ausgeblendete Hilfsspalte: =WENN(A1=A2;"";1) bei mir B
Daneben: =ZÄHLENWENN(B1:B500;1)

Die Zellwert musst du anpassen.

Gruß Heinz

nach oben   nach unten

Re: Elemente einer Datumsreihe
von: Calin
Geschrieben am: 10.07.2002 - 13:04:20

Hallo Andreas

> mit Leerzellen:
> {=SUMME(WENN(A1:A100="";0;1/ZÄHLENWENN(A1:A100;A1:A100)))}

Super, genau das wars! Danke!
Wobei ich als Excel-Banause den Unterschied zwischen
Formel -> Enter
und
Formel -> Strg + Shift + Enter
natürlich nicht verstanden habe. Aber es funktioniert.
Danke nochmal, auch an Heinz ;-)

Gruß,
Calin

 nach oben

Beiträge aus den Excel-Beispielen zum Thema "Elemente einer Datumsreihe"