Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Anzahl der Urlaubstage zählen

Anzahl der Urlaubstage zählen
02.10.2013 08:26:15
Matthias
Hallo!
Für eine monatliche Stundenverwaltung von mehreren Mitarbeitern würde ich gerne die Anzahl der Urlaubstage pro Monat automatisch auslesen lassen. Dazu muss zunächst die Spalte in der Urlaubsliste bestimmt werden, in der sich der jeweilige Mitarbeiter befindet, und dann die Anzahl der "u" Einträge in einem bestimmten Monat gezählt werden.
Das ganze sollte möglichst mit einer einzigen Formel und ohne zusätzliche Spalten gelöst werden. Hier die (vereinfachte) Datei:
https://www.herber.de/bbs/user/87496.xlsx
Vielen Dank im Voraus,
Gruß Matthias

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl der Urlaubstage zählen
02.10.2013 09:06:08
Crossposter
Hallo,
=SUMMENPRODUKT((Urlaub!B1:D1=B1)*(MONAT(Urlaub!A2:A366)=B2)*(Urlaub!B2:D366="U"))
Gruß
Rudi

Crossposter-bitte ändern ;-) owT Gruß
02.10.2013 09:27:54
robert

Erwischt! Letzte Nachricht gesehen? ;-) Gruß owT
02.10.2013 15:17:37
Luc:-?
:-?

Erledigt! Gesehen! ;-) owT
02.10.2013 15:25:36
Luc:-?
:-?

AW: Anzahl der Urlaubstage zählen
02.10.2013 09:08:18
Hajo_Zi
Hallo Matthias,



Auswertung
 B
1'Ralf
21
33

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B3=SUMMENPRODUKT((MONAT(Urlaub!A2:A366) =Auswertung!B2) *(INDIREKT(ADRESSE(2;VERGLEICH(B1;Urlaub!A1:D1;0) ;;;"Urlaub") &":"&ADRESSE(366;VERGLEICH(B1;Urlaub!A1:D1;0) ) ) ="U") )   =SUMPRODUCT((MONTH(Urlaub!R[-1]C[-1]:R[363]C[-1]) =Auswertung!R[-1]C) *(INDIRECT(ADDRESS(2,MATCH(R[-2]C,Urlaub!R[-2]C[-1]:R[-2]C[2],0) ,,,"Urlaub") &":"&ADDRESS(366,MATCH(R[-2]C,Urlaub!R[-2]C[-1]:R[-2]C[2],0) ) ) ="U") )

XHTML Tabelle für Darstellung in Foren,
einschl. Bedingter Formatierung ab Version 2007
XHTML-Version 11.49 einschl 64 Bit Version




Anzeige

312 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige