Microsoft Excel

Herbers Excel/VBA-Archiv

Summe bilden bei neuen Monat

Betrifft: Summe bilden bei neuen Monat von: Wolfgang
Geschrieben am: 17.03.2014 19:44:24

Hallo,
im Internet habe ich bis jetzt noch keine Lösung gefunden. Vielleicht liege ich auch mit meinen Gedanken etwas falsch.
Wie in der Beispieldatei zu sehen, habe ich in der Spalte A das Datum eingetragen und nun wollte ich in Spalte K die Summe vom vergangenen Monat aufgerechnet haben.
Meine Versuche sind in den Spalten H und J vorhanden, aber die Ergebnisse passen nicht.

https://www.herber.de/bbs/user/89703.xlsx

Wo liegt mein Denkfehler?

mfg
Wolfgang

  

Betrifft: AW: Summe bilden bei neuen Monat von: Christian
Geschrieben am: 17.03.2014 20:14:32

Hallo Wolfgang,

war doch fast richtig, nur die Bezüge waren nicht korrekt!
Vorschlag ab K5:
=WENN(ODER(MONAT(A5)<>MONAT(A6);ZEILE()=VERWEIS(2;1/($A$1:$A$250<>"");ZEILE($1:$250))); SUMMENPRODUKT((MONAT($A$5:A5)=MONAT(A5))*(JAHR($A$5:A5)=JAHR(A5))*($B$5:B5));"")

MfG Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Summe bilden bei neuen Monat"