Microsoft Excel

Herbers Excel/VBA-Archiv

heute()+x ohne samstag/sonntag

Betrifft: heute()+x ohne samstag/sonntag von: Spenski
Geschrieben am: 05.06.2014 22:43:28

huhu

https://www.herber.de/bbs/user/91014.xlsx

über heute()+/-x zieh ich mir über sverweise usw aktuelle daten. ist es möglich das samstage und sonntage nicht beachtet werden?? also er nur mit werkstagen rechnet???

gruss
christian

  

Betrifft: AW: heute()+x ohne samstag/sonntag von: Spenski
Geschrieben am: 05.06.2014 23:29:12

=WENN(TEXT(A39-1;"tttt")="Samstag";A39-2;WENN(TEXT(A39-1;"tttt")="Sonntag";A39-3;A39-1))

hat sich erledigt


  

Betrifft: AW: heute()+x ohne samstag/sonntag von: Hajo_Zi
Geschrieben am: 06.06.2014 07:00:16

ich beziehe mich mal auf den Betreff.

Tabelle1

 AB
106.06.201409.06.2014

verwendete Formeln
Zelle Formel Bereich N/A
B1=ARBEITSTAG(A1;1)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.26 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: heute()+x ohne sam./sonn. Feiertag von: Hajo_Zi
Geschrieben am: 06.06.2014 07:37:55


Tabelle1

 AB
106.06.201410.06.2014

verwendete Formeln
Zelle Formel Bereich N/A
B1=ARBEITSTAG(A1;1;Frei!B3:B32)  


Frei
 AB
1Jahr2014
2 Feiertag im
Bundesland
301.01.201401.01.2014
406.01.201406.01.2014
503.03.2014 
618.04.201418.04.2014
719.04.2014 
820.04.201420.04.2014
921.04.201421.04.2014
1001.05.201401.05.2014
1129.05.201429.05.2014
1211.05.2014 
1307.06.2014 
1408.06.201408.06.2014
1509.06.201409.06.2014
1619.06.201419.06.2014
1715.08.201415.08.2014
1803.10.201403.10.2014
1905.10.2014 
2031.10.2014 
2101.11.201401.11.2014
2216.11.2014 
2319.11.2014 
2423.11.2014 
2530.11.2014 
2607.12.2014 
2714.12.2014 
2821.12.2014 
2924.12.2014 
3025.12.201425.12.2014
3126.12.201426.12.2014
3231.12.2014 
33  
3430.03.2014 
3526.10.2014 

verwendete Formeln
Zelle Formel Bereich N/A
A3=DATWERT("01.01."&B1)  
A4=DATWERT("06.01."&B1)  
A5=A8-48  
A6=A8-2  
A7=A8-1  
A8=DM((TAG(MINUTE(B1/38)/2+55) & ".4." & B1)/7;)*7-WENN(JAHR(1)=1904;5;6)  
A9=A8+1  
A10=DATWERT("01.05."&B1)  
A11=A8+39  
A12=DATUM(B1;5;1)+15-WOCHENTAG(DATUM(B1;5;1))  
A13=A8+48  
A14=A8+49  
A15=A8+50  
A16=A8+60  
A17=DATUM(B1;8;15)  
A18=DATWERT("03.10."&B1)  
A19=DATUM(B1;10;1)+7-WOCHENTAG(DATUM(B1;10;1);2)  
A20=DATWERT("31.10."&B1)  
A21=DATWERT("01.11."&B1)  
A22=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-35  
A23=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-32  
A24=DATUM(B1;12;25)-WOCHENTAG(DATUM(B1;12;25);2)-28  
A25=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-21  
A26=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-14  
A27=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)-7  
A28=DATUM($B$1;12;25)-WOCHENTAG(DATUM($B$1;12;25);2)  
A29=DATWERT("24.12."&B1)  
A30=DATWERT("25.12."&B1)  
A31=DATWERT("26.12."&B1)  
B3:B4,B6,B8:B11,B14:B18,B21,B30:B31=A3  
A32=DATWERT("31.12."&B1)  
A34=DATUM(B1;3;31)-REST(WOCHENTAG(DATUM(B1;3;31);2);7)  
A35=DATUM(B1;11;)-WOCHENTAG(DATUM(B1;11;);1)+1  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 17.26 einschl. 64 Bit



Gruß Hajo