Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt zwischen zwei Dati

Betrifft: Summenprodukt zwischen zwei Dati von: Clemens S
Geschrieben am: 17.06.2014 10:01:15

Hallo zusammen!

Bis jetzt konnte ich alle Probleme mit der Suchfunktion lösen. Diesmal finde ich leider keinen Weg.

Ich habe ein Tabellenblatt mit allen Daten namens "Daten":

Buchungsdatum KundenNr. Produktion
05.06.2014 75234 10000
04.04.2014 75222 5000
05.05.2014 75234 5000
02.02.2014 75234 2000

Das Summenprodukt brauche ich in einem anderen Tabellenblatt:

Kundennummer BeginnAktion EndeAktion ProduktionAktion
75222 01.03.2014 30.04.2014 SUMMENPRODUKT
75234 01.05.2014 30.06.2014 SUMMENPRODUKT

Damit habe ich es versucht:
=SUMMENPRODUKT((Daten!buchungsdatum>=DATWERT(Beginnaktion))*(Daten!buchungsdatum<=DATWERT(Endeaktion) )*DATEN(Daten!kundenNr=KundenNr)*Daten!produktion)

Ich bekomme jedoch immer einen Zahlenfehler...

Bitte um Hilfe

  

Betrifft: AW: Summenprodukt zwischen zwei Dati von: Nepumuk
Geschrieben am: 17.06.2014 10:14:59

Hallo,

lass DATWERT weg, oder stehen in deinen Vergleichszellen (Beginnaktion / Endeaktion) keine Daten sondern Zeichenketten?

Gruß
Nepumuk


  

Betrifft: AW: Summenprodukt zwischen zwei Dati von: Clemens S
Geschrieben am: 17.06.2014 10:32:56

DATWERT habe ich weggelassen, der Fehler lag aber darin, dass ich bei den Matrizen die Überschriftenzeile mitgenommen habe...
Ich denke, es funtkioniert jetzt!

VIELEN DANK


  

Betrifft: vorausgesetzt ... von: der neopa
Geschrieben am: 17.06.2014 10:23:14

Hallo Clemens,

... es gab die dyn. Tabellen schon in XL2003, dann z.B. so:

Ergebnis

 ABCD
1KundennummerBeginnAktionEndeAktionProduktionAktion
27522201.03.201430.04.20145000
37523401.05.201430.06.201415000

Formeln der Tabelle
ZelleFormel
D2=SUMMENPRODUKT((Tabelle1[Buchungsdatum]>=[@BeginnAktion])*(Tabelle1[Buchungsdatum]<=[@EndeAktion])*(Tabelle1[KundenNr.]=[@Kundennummer])*Tabelle1[Produktion])
D3=SUMMENPRODUKT((Tabelle1[Buchungsdatum]>=[@BeginnAktion])*(Tabelle1[Buchungsdatum]<=[@EndeAktion])*(Tabelle1[KundenNr.]=[@Kundennummer])*Tabelle1[Produktion])


Daten

 ABC
1BuchungsdatumKundenNr.Produktion
205.06.20147523410000
304.04.2014752225000
405.05.2014752345000
502.02.2014752342000


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: und ncht vorausgesetzt ... von: der neopa
Geschrieben am: 17.06.2014 10:28:31

Hallo Clemens,

... z.B. einfach so:

=SUMMENPRODUKT((Daten!A$2:A$99>=B2)*(Daten!A$2:A$99<=C2)*(Daten!B$2:B$99=A2)*Daten!C$2:C$99)

Gruß Werner
.. , - ...


  

Betrifft: AW: und ncht vorausgesetzt ... von: Clemens S
Geschrieben am: 17.06.2014 10:45:09

@Werner: Vielen Dank!!! Jetzt funktioniert es


 

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt zwischen zwei Dati"