Microsoft Excel

Herbers Excel/VBA-Archiv

Zwei Tabellen zusammenführen

Betrifft: Zwei Tabellen zusammenführen von: D. Skinner
Geschrieben am: 25.07.2014 11:24:19

Hallo zusammen,
mal wieder ein für euch sicher kleines Thema, für das ich Unterstützung benötige:

Ich habe eine Tabelle mit Firmen und IDs sowie eine zweite Tabelle mit den IDs und einer spezifischen Reihenfolge. Diese beiden sollen zusammengeführt werden, damit jede Firma mit ID und Reihenfolge in einer Tabelle steht.
Hierzu hier ein Beispiel das es hoffentlich sehr anschaulich macht: https://www.herber.de/bbs/user/91718.xlsx

Beste Grüsse
Daniel

  

Betrifft: AW: Zwei Tabellen zusammenführen von: Christian
Geschrieben am: 25.07.2014 12:12:43

Hallo Daniel,

ein Ansatz ohne VBA, mit einer Hilfsspalte in der Tabelle ID_Reihenfolge:
(Wobei ich nicht getestet habe, ob die Rechenzeit vertretbar ist, da ich keine lange Liste erstellt habe...)

 ABC
1ReihenfolgeID 
2110003
3220002
4310003
5415002
6515002
7620002
8710003

Formeln der Tabelle
ZelleFormel
C2=ZÄHLENWENN('Begriff ID'!B:B;B2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

 ABC
1ReihenfolgeIDBegriff
211000Test A
311000Test C
411000Test G
522000Test B
622000Test F
731000Test A
831000Test C
931000Test G
1041500Test D
1141500Test E
1251500Test D
1351500Test E
1462000Test B
1562000Test F
1671000Test A
1771000Test C
1871000Test G

Formeln der Tabelle
ZelleFormel
A2='ID Reihenfolge'!A2
B2=WENN(A2="";"";SVERWEIS(A2;'ID Reihenfolge'!A:B;2;0))
C2{=WENN(A2="";"";INDEX('Begriff ID'!A:A;KKLEINSTE(WENN('Begriff ID'!$B$1:$B$10000=B2;ZEILE($A$1:$A$10000)); ZÄHLENWENN($A$2:A2;A2))))}
A3=WENN(ZEILE(A2)>SUMME('ID Reihenfolge'!C:C); "";WENN(ZEILE(A2)>SUMME('ID Reihenfolge'!$C$2:INDEX('ID Reihenfolge'!C:C;VERGLEICH(A2;'ID Reihenfolge'!A:A;0))); INDEX('ID Reihenfolge'!A:A;VERGLEICH(A2;'ID Reihenfolge'!A:A;0)+1); A2))
B3=WENN(A3="";"";SVERWEIS(A3;'ID Reihenfolge'!A:B;2;0))
C3{=WENN(A3="";"";INDEX('Begriff ID'!A:A;KKLEINSTE(WENN('Begriff ID'!$B$1:$B$10000=B3;ZEILE($A$1:$A$10000)); ZÄHLENWENN($A$2:A3;A3))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: Zwei Tabellen zusammenführen von: D. Skinner
Geschrieben am: 25.07.2014 14:18:09

Hallo Christian,
das scheint meine Anforderungen voll und ganz zu erfüllen. KKleinste kannte ich bisher nicht, Merci vielmals für eine Lösung ohne VBA.
Nettes Wochenende Dir
Daniel


 

Beiträge aus den Excel-Beispielen zum Thema "Zwei Tabellen zusammenführen"