Microsoft Excel

Herbers Excel/VBA-Archiv

verschwundene Zeilen

Betrifft: verschwundene Zeilen von: rene
Geschrieben am: 29.07.2014 23:02:37

https://www.herber.de/bbs/user/91773.xls
Guten Abend

versuche schlafzeiten für Sonntag zu ermitteln , dazu hab ich in I die Schlafzeit, in B die Bezüge für verschiedene Tage, die in N3-N12 deutlicher werden , nur ich
komme nicht dahinter , warum in R11 nicht das richtige Ergebnis kommt .
Liegt es vllt daran ,daß Zeile 258-259 nicht existiert und ich nicht weiß wie ich die her bekomme.
238 fehlt der Bezug in B , aber das dürfte nicht das Problem sein.
Soweit erstmal
Vielen Dank schonmal
gruß Rene

  

Betrifft: AW: verschwundene Zeilen von: Mullit
Geschrieben am: 30.07.2014 00:48:40

Hallo,

Liegt es vllt daran ,daß Zeile 258-259 nicht existiert und ich nicht weiß wie ich die her bekomme.
wie jetzt, 'nicht her bekomme' ?

Zeile 257 + 260 markieren >>> re. Maustaste >>> Einblenden anklicken....

Gruß,


  

Betrifft: AW: verschwundene Zeilen von: rene
Geschrieben am: 30.07.2014 03:48:22

Hallo

wie das fehlen der Zeilen zustande kam , hab ich beim suchen der einblendfunktion heraus gefunden und selbst bei 400% vergrößern krieg ich sie nicht markiert.
was aber ist mit dem Ergebnis in R11?
kann da jemand weiterhelfen?
danke
gruß rene


  

Betrifft: AW: verschwundene Zeilen von: Hajo_Zi
Geschrieben am: 30.07.2014 07:12:42

Hallo Rene,

alle Bereiche sollten die gleiche Größe haben. Das Ergebnis ist korrekt.

Sheet1

 RST
114,042   
22524,2524,25Kontrolle
22666 
2274,041666666666674,04166666666667 

verwendete Formeln
Zelle Formel Bereich N/A
R11=SUMMEWENN($B$226:$B$317;N11;$I$226:$I$317)/ZÄHLENWENN($B$226:$B$317;N11)  
R225=SUMMEWENN($B$226:$B$317;N11;$I$226:$I$317)  
S225=SUMMENPRODUKT(($B$226:$B$317=N11)*($I$226:$I$317))  
R226=ZÄHLENWENN($B$226:$B$317;N11)  
S226=SUMMENPRODUKT(($B$226:$B$317=N11)*1)  
R227:S227=R225/R226  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.09 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: Zeilen einblenden von: Rudi Maintaire
Geschrieben am: 30.07.2014 10:02:40

Hallo,
und selbst bei 400% vergrößern krieg ich sie nicht markiert.
Dann markiere eben 257-260.

Gruß
Rudi


  

Betrifft: diese spielen keine Rolle ... von: der neopa
Geschrieben am: 30.07.2014 08:21:48

Hallo Rene,

... mit folgender alternativen Matrixformel, ermittele ich das gleiche Ergebnis:

 R
114,042

Formeln der Tabelle
ZelleFormel
R11{=MITTELWERT(WENN(B226:B317=9;I226:I317))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Noch ein Hinweis: wenn Du in Deiner Spalte G echte Exceldatumswerte erfasst hättest, würde Deine Auswertung sich weiter vereinfachen. Dies gilt analog auch für die Erfassung der Start und Endzeiten in getrennten Spalten anstelle Deine Textwerte in Spalte A.


Gruß Werner
.. , - ...


  

Betrifft: AW: diese spielen keine Rolle ... von: rene
Geschrieben am: 30.07.2014 18:29:49

Danke erstmal an alle,

wenn ihr in der Tabelle auch das gleiche rausbekommt , wo dann , liegt der Fehler.
Das Ergebnis in R11 kann nicht richtig sein.

habe mal ein neues Blatt gemacht ,die Formel auf nur 4 ZEILEN gekürzt und die Zeiten aus I in Bezug auf B und zählen wenn N11=9 gesetzt und komme auf 6.0625. Und das stimmt dann.

wenn in Zeile 238 in B nicht text stehen würde dann kämen noch mal 9 h dazu und dann wäre der Schnitt 8.3125.
Diese Zeile 238 würde ich gerne in B dwn Text stehen lassen und am liebsten soll B 238 als Bezugszelle dienen , gibt es da die Möglichkeit einer Hilfszelle?
Wäre es denkbar Zelle AG so zu formatieren , daß dort steht, welchen Bezug B 238 hat, trotz Text?
danke
gruß Rene


  

Betrifft: gelöst , aber bitte eine Frage hab ich noch von: rene
Geschrieben am: 30.07.2014 23:52:19

Danke nochmal an mulit , hajo, rudi und neopa für eure Hilfe

habe den Fehler gefunden , in den Zeilen 258,259 , die nicht mehr sichtbar waren , befand sich in Spalte B eine 9 , dadurch stimmte der Durchschnitt nicht, was zu dem falschen Ergebnis in R11 führte .
Und nach mehrmaligen Lesen eurer Antworten , verstand ich wie das mit dem Löschen ging.

Eine Frage zu dieser Tabelle hätte ich noch .
Zelle B238 hab ich einen Text reingeschrieben , brauche aber eigentlich eine Bezugszahl in dieser Zelle , gibt es die Möglichkeit , irgendeine freie Zelle zu nehmen und in dieser zu sagen, daß B238 die 9 ist?
gruß Rene


  

Betrifft: es geht mE um viel mehr ... von: der neopa
Geschrieben am: 31.07.2014 17:23:38

Hallo Rene.

... ich merke gerade, dass Dein letzte Anfrage noch offen war.

Was Du als Fragestellung beschreibst, ist zwar realisierbar, löst aber noch nicht Deine eigentliche Aufgabenstellung.

Wie ich bereits schon geschrieben hatte, hättest Du das ganze leichter haben können, wenn Du von vornherein mit echten Datumswerten (anstelle Deiner Textdatumsangaben in Spalte G) gearbeitet hättest. Hinzu kommt noch, wie ich eben feststellte, dass die bisherige berechneten Durchschnittswerte mE falsch sind, weil diese auch die noch nicht erfassten Zeitangaben in Spalte I als 0 mit ein berechnen.

Nun, die Textdatumswerten der Spalte G lassen sich zumindest anstelle der Kennung in Spalte B nutzen. Somit würde unter Berücksichtigung des vorgenannten mit folgende Lösungsformel sich folgender (mE nun richtiger Wert) ergeben:

Sheet1

 P
2388,3125

Formeln der Tabelle
ZelleFormel
P238{=MITTELWERT(WENN((LINKS(G226:G317;2)="So")*(I226:I317>0); I226:I317))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: es geht mE um viel mehr ... von: rene
Geschrieben am: 31.07.2014 22:50:00

Guten Abend Werner

deine Matrixformel gibts die auch als normale Formel? weil ich nicht weiß wie ich die Formel auf meinem Smartphone abschliessen kann und dann hab ich auch noch ein englisches Excel von Polaris Office .
nachdem ich mit eurer Hilfe mein Problem lösen konnte , kam ich auf das gleiche Ergebnis .
Die noch nicht beschriebenen Tage , nehmen keinen Einfluss , weil ich ja täglich in B dann erst den Bezug rein schreibe und somit die Formel in R nicht ordnen kann.
Fürs nächste Jahr plan ich eine echte Datums Tabelle und da hätte ich die bitte , mir , ein gutes Excel Lernbuch zu empfehlen .
Glaube , die Aufgabenstellung gelöst zu haben und wollte nochmal die Frage mit der Hilfszelle wie in vorheriger Antwort beschrieben , anfragen , wenn's nicht zu viel Umstände macht .
Und noch eine Frage zu dieser Tabelle .
Geht das? , wenn in einer Zelle zb P1 5 verschiedene Zahlen stehen , möchte ich 5 Zellen , wo jede eine dieser 5 Zahlen anzeigt .
wünsche eine gute Nacht
Gruß Rene


  

Betrifft: AW: es geht mE um viel mehr ... von: rene
Geschrieben am: 31.07.2014 22:50:01

Guten Abend Werner

deine Matrixformel gibts die auch als normale Formel? weil ich nicht weiß wie ich die Formel auf meinem Smartphone abschliessen kann und dann hab ich auch noch ein englisches Excel von Polaris Office .
nachdem ich mit eurer Hilfe mein Problem lösen konnte , kam ich auf das gleiche Ergebnis .
Die noch nicht beschriebenen Tage , nehmen keinen Einfluss , weil ich ja täglich in B dann erst den Bezug rein schreibe und somit die Formel in R nicht ordnen kann.
Fürs nächste Jahr plan ich eine echte Datums Tabelle und da hätte ich die bitte , mir , ein gutes Excel Lernbuch zu empfehlen .
Glaube , die Aufgabenstellung gelöst zu haben und wollte nochmal die Frage mit der Hilfszelle wie in vorheriger Antwort beschrieben , anfragen , wenn's nicht zu viel Umstände macht .
Und noch eine Frage zu dieser Tabelle .
Geht das? , wenn in einer Zelle zb P1 5 verschiedene Zahlen stehen , möchte ich 5 Zellen , wo jede eine dieser 5 Zahlen anzeigt .
wünsche eine gute Nacht
Gruß Rene


  

Betrifft: dann ohne {} ... von: neopa C (paneo)
Geschrieben am: 01.08.2014 09:00:13

Hallo Rene,

... dann z.B. so:

=SUMMENPRODUKT((LINKS(G226:G317;2)="So")*(B226:B317<>"")*(I226:I317<>"");I226:I317) / SUMMENPRODUKT((LINKS(G226:G317;2)="So")*(B226:B317<>"")*(I226:I317<>""))

mit dem gleichen Ergebnis wie meine letzte MITTELWERT()-Formel.

Und ein Excelbuch kann ich Dir mangels selbst nicht gelesen somit nicht empfehlen. Allerdings eine gute Seite: http://www.online-excel.de/

Gruß Werner
.. , - ...


  

Betrifft: ach ja, noch zu Deiner letzten Teilfrage ... von: neopa C (paneo)
Geschrieben am: 01.08.2014 09:07:20

Hallo Rene.

... und zwar dieser: "...wenn in einer Zelle zb P1 5 verschiedene Zahlen stehen , möchte ich 5 Zellen , wo jede eine dieser 5 Zahlen anzeigt"
gibt es zwei Lösungsansätze. Zum einen über: Menü:, Daten, Text in Spalten und entsprechend trennen. oder über eine Formellösung. Bei beiden müsste allerdings klar sein, wei die Trennung der Zahlen vorliegt. (Z.B über Komma, Leerzeichen, Umbruch etc.)


Gruß Werner
.. , - ...


  

Betrifft: AW: meine Datei ist einfach weg ... von: rene
Geschrieben am: 01.08.2014 17:54:13

Hallo Werner

so gerne ich die Formel ausprobieren würde , ist mein Arbeitskalender spurlos verschwunden , heut morgen noch Sachen eingetragen und jetzt wollte ich wieder Einträge machen , weg.
Liegt es vllt auch daran , daß ich bei jedem Eintrag immer auf speichern drücke? Die Sicherungsspeichern hatte ich abgestellt , weil er jedesmal eine Sicherung machte.
Vor 14 Tagen hatte ich in Onlinespeicher gesichert , muss jetzt 14 tage versuchen zu rekonstruieren .

Trotzalledem vielen riesigen Dank , die Formel probier ich demnächst und die Sache mit den 5 Daten in einer Zelle , geht bei mir nur über eine Formellösung und als Trennung hab ich das Komma ( hab englische Formeln)
Ein schönes Wochenende
lg Rene


  

Betrifft: Sicherung ist und bleibt das A-O ... von: neopa C (paneo)
Geschrieben am: 04.08.2014 10:48:26

Hallo Rene,

... aber durch häufiges Speichern, kann keine Datei "verschwinden". Dafür gibt es sichere andere Gründe/Ursachen, die ich natürlich von ferne nicht erklären kann.

Zu der von Dir gewünschten Formellösung, hier mein Vorschlag:

 PQ
111,  9  ,1234  ,  5  ,789 11
2 9
3 1234
4 5
5 789

Formeln der Tabelle
ZelleFormel
Q1=MID(","&SUBSTITUTE($P$1," ",""),FIND("#",SUBSTITUTE(","&SUBSTITUTE($P$1," ",""),",","#",ROW(A1)))+1,FIND(",",MID(","&SUBSTITUTE($P$1&","," ",""),FIND("#",SUBSTITUTE(","&SUBSTITUTE($P$1," ",""),",","#",ROW(A1)))+1,99))-1)+0


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: das war eine Arbeit ... von: rene
Geschrieben am: 06.08.2014 02:08:59

Hallo Werner

ja da hast du recht ,hatte 14 Tage davor in die Cloud gespeichert und musste jetzt 14 Tage rekonstruieren
, was gar nicht so einfach war. Die wichtigsten Daten hab ich aber.
Habe mal diese Formel eingegeben und in P1 35.01, 22.6, 1.549, 135946,203.4 reingeschrieben ,
in den Ausgabe Zellen bringt er 35.01 , 22.6 , 0.549 , 5946 , 0.4

kann es sein, daß ich was falsch mache. Habe mir irgendeine Zelle genommen , wo Platz nach unten ist, die Formel eingegeben , die Zelle markiert und 5 Zellen nach unten gezogen . Oder muss ich es anderst machen?
lg Rene


  

Betrifft: klappt noch nicht ganz von: rene
Geschrieben am: 06.08.2014 11:13:14

Hallo Werner ,

auf einen neuen Blatt geht es, muss also in meiner Tabelle schauen ,daß es dort auch geht.
Nur wenn ich jetzt in P2 was eingebe, verändert sich die Zahl nicht in den" AusgabeZellen".
Hab die Formel mal erweitert , überall wo $P$1 stand , hab ich $P$1:$P$385 draus gemacht , dann kommt #Value
Ich bin noch nicht so gut , das zu lösen , kannst du mir da bitte nochmal helfen .
Danke
lg Rene


 

Beiträge aus den Excel-Beispielen zum Thema "verschwundene Zeilen "