Microsoft Excel

Herbers Excel/VBA-Archiv

SVerweise

Betrifft: SVerweise von: gk
Geschrieben am: 01.08.2014 17:00:26

Hallo!

Ich habe bei dem SVERWIS ein Problem. Wenn zwei oder mehrere Punkte gleich sind, dann erhalte ich bei der Sortierung ab dem zweiten den Wert "#NV".

Weiters würde ich gerne die drei Tabellen im Arbeitsblatt "Rang" auf eine zusammenfügen. Leider bekomme ich, das nicht richtig hin. Es passen dann keine Verweise mehr.
Am Schluss sollte dann eine Tabelle mit automatischer Rang-Sortierung, Name, Punkteanzahl und Gewinnbetrag in € und Prozent angezeigt werden.
Die Prozenttabelle sollte so sein, dass der Potbetrag problemlos auf den Rang aufgeteilt werden kann.

Ich hoffe, dass das jemand hinbekommt.

Danke.

https://www.herber.de/bbs/user/91832.xls

  

Betrifft: AW: SVerweise von: Christian
Geschrieben am: 01.08.2014 17:37:24

Hallo Gerhard,

ein Ansatz:

 EFGHIJKLMN
1          
2RangNamePunkte PlatzGewinn%   
31Spieler 046 1     250,00 € 50 Spieleranzahl50
42Spieler 245 2     100,00 € 20 Tippschein         10 €
53Spieler 344 3       75,00 € 15 Pot       500 €
64Spieler 444 4       50,00 € 10   
75Spieler 541 5       25,00 € 5   
86Spieler 138 6             -   €     

Formeln der Tabelle
ZelleFormel
E3=WENN(G3="";"";ZEILE(A1))
F3{=WENN(G3="";"";INDEX(Tippliste!$A$1:$CV$1;KKLEINSTE(WENN((Tippliste!$A$4:$CV$4=G3); SPALTE($A$1:$CV$1)); ZÄHLENWENN($G$3:G3;G3))-3))}
G3=WENN(ZEILE(A1)>ANZAHL(Tippliste!$4:$4); "";KGRÖSSTE(Tippliste!$4:$4;ZEILE(A1)))
I3=WENN(ZEILE(A1)>MAX(E:E); "";ZEILE(A1))
J3=WENN(I3<>"";$N$5/100*K3;"")
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

MfG Christian


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 01.08.2014 18:35:49

Danke einmal, aber leider mit der Zelle F3 funktioniert es nicht.

Wie mache ich das mit den Prozenten, dass ich nur max 100% insgesamt vergeben kann. ansonsten soll zb die Spalte Prozent rot sein. Super wäre auch eine Zelle mit Prozentangabe, wo steht wieviel Prozent schon vergeben sind und wie viel noch vergeben werden können.


https://www.herber.de/bbs/user/91834.xlsx


  

Betrifft: AW: SVerweise von: Christian
Geschrieben am: 01.08.2014 18:48:47

Hallo Gerhard,

der Ansatz funktioniert, Du musst nur die Formel als Matrixformel abschließen, siehe den Hinweis dazu!
Mit Deiner Level-Angabe sollte es auch kein Problem sein, dass Du mit den Stichworten "Datenüberprüfung" oder Bedingte Formatierung die Eingaben in der Prozentspalte überprüfst!

MfG Christian


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 01.08.2014 18:58:27

Leider komme ich jetzt nicht weiter mit dem Hinweis. Wo finde ich diesen?


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 01.08.2014 18:58:32

Leider komme ich jetzt nicht weiter mit dem Hinweis. Wo finde ich diesen?


  

Betrifft: AW: SVerweise von: Christian
Geschrieben am: 01.08.2014 19:09:07

Hallo Gerhard, (Anrede)

da müssen wir doch weiter ausholen.
Wie viele Leute nehmen an dem Tippspiel teil?
Wie ist die Verteilung des Pots geregelt?
Erhalten immer nur die ersten fünf Beträge aus dem Pot, oder ist es abhängig von der Anzahl der Teilnehmer, wenn ja, nach welchem Muster wird verteilt?

MfG Christian (Gruß)


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 01.08.2014 23:02:57

Hallo.
Wegen der Aufteilung, es sollten ca bis zu 10 personen beteiligt sein.
Aber auch bei punktegleichheit soll es beruecksichtigt werden.

Wegen der matrixformel komme ich leider nicht alleine weiter.


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 02.08.2014 13:32:56

Jetzt habe ich alles hinbekommen, ausser....
was noch fehlt sind die Anzahl und Berechnung bei Punktegleichheit.
Wie kann ich das machen? Es sollen bei Punktegleichheit auch die Platzierung und der Gewinn gleich sein.

https://www.herber.de/bbs/user/91841.xlsx


  

Betrifft: AW: SVerweise von: gk
Geschrieben am: 03.08.2014 16:49:50

Hallo!
Meine Matrixformel im Tabellenblatt Rang auf F3 spielt verrückt.
Immer wenn ich im Tabellenblatt Tippliste einen neuen Tipp am Ende des bestehenden hinzukopiere, stimmt meine Matrixformel nicht mehr. Diese Formel wollte ich auch bis auf "XFD1" (letzte Spalte im Excel) erweitern. Leider ohne Erfolg.

Die Berechnung bei Punktegleichheit- dass der gleiche Rang und somit gleiche Gewinn angezeigt wird, funktioniert leider auch noch nicht.

Vl kann mir jemand weiterhelfen.
Danke.

https://www.herber.de/bbs/user/91852.xlsx