Microsoft Excel

Herbers Excel/VBA-Archiv

Zellen mit Zahl und Text summieren

Betrifft: Zellen mit Zahl und Text summieren von: Manfred
Geschrieben am: 05.08.2014 09:19:32

Hallo zusammen,

ich stehe gerade auf dem Schlauch und komme nicht weiter.
Ich glaube ich habe da einen Denkfehler.

In den Zeilen C5-L5 stehen mal 1, 5, 5v, 8v, 7, usw.
Nun möchte ich die Summe der Zahlen mit "v" errechnen, bekomme aber immer die Fehlermeldung #Wert. Im Beispiel hier wäre die Summe 13 richtig.

Ich benutze die Formel =SUMME(LINKS(C5:L5;FINDEN("";C5:L5))*1)
Wenn es geht würde ich kein Leerzeichen setzen.

Kann mir bitte jemand sagen was ich falsch mache ?
Ein Beispiel habe ich mit hochgeladen.

https://www.herber.de/bbs/user/91896.xls

Mit freundlichen Grüßen
Manfred

  

Betrifft: mit WECHSELN() ... von: neopa C (paneo)
Geschrieben am: 05.08.2014 09:24:42

Hallo Mafred,


... so: {=SUMME(WENN(ISTZAHL(FINDEN("v";C5:L5));--WECHSELN(C5:L5;"v";"")))}

Gruß Werner
.. , - ...


  

Betrifft: AW: mit WECHSELN() ... von: Manfred
Geschrieben am: 05.08.2014 12:28:47

Hallo Werner,

merci für die Antwort. Auch bei deiner Formel erhalte ich den Wert 0.

Ich weis nicht was ich falsch mache.

Gruß
Manfred


  

Betrifft: AW: Zellen mit Zahl und Text summieren von: Hajo_Zi
Geschrieben am: 05.08.2014 09:26:19

Hallo Manfred,

ich hätte 19 gesehen.

Tabelle1

 BC
5191

verwendete Formeln
Zelle Formel Bereich N/A
B5{=SUMME(WENN(ISTZAHL(FINDEN(" ";C5:L5));LINKS(C5:L5;FINDEN(" ";C5:L5))*1))}$B$5 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.12 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: @ Hajo von: Christian
Geschrieben am: 05.08.2014 09:37:04

Hallo Hajo,

wie kommst Du auf 19?

MfG Christian


  

Betrifft: AW: schaue in Datei von: Hajo_Zi
Geschrieben am: 05.08.2014 09:39:22

Hallo Christian,


Tabelle1

 EGHL
52 v3 v4 v10 v
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.12 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: schaue in Datei von: Christian
Geschrieben am: 05.08.2014 09:48:16

Hallo Hajo,

aber nicht fürs genannte Beipiel im Thread ;-)

MfG Christian


  

Betrifft: AW: schaue in Datei von: Hajo_Zi
Geschrieben am: 05.08.2014 09:52:45

Hallo Christian,

dann habe ich die Forderung in der Datei falsch interpretiert.



Gruß Hajo


  

Betrifft: verstehe Deine Frage momentan auch nicht ... von: neopa C (paneo)
Geschrieben am: 05.08.2014 10:43:27

Hallo Christian,

... für das konkrete Beispiel ergibt auch Hajos Formel doch ein korrektes Ergebnis.

Die Lösung über das FINDEN() des LEERZEICHENS hat nur ein kleinen Nachteil, sie erfordert zusätzlich zu dem "v" auch das Leerzeichen und das erst nach der Zahl. Ansonsten ergibt sich ein möglicherweise ungewolltes Ergebnis. Dies bzgl. ist mein Formelvorschlag weniger empfindlich, weil dies zusätzliche /falsch gesetzte Leerzeichen einfach ignoriert.

Gruß Werner
.. , - ...


  

Betrifft: AW: Zellen mit Zahl und Text summieren von: Manfred
Geschrieben am: 05.08.2014 12:24:48

Hallo Hajo,

danke für die Antwort. Alls Eregebnis erhalte ich aber den Wert 0.

Was mache ich falsch ?

Gruß
Manfred


  

Betrifft: {} Matrixformel mit Strg+Umschalt+Enter abschließe von: robert
Geschrieben am: 05.08.2014 12:29:20




  

Betrifft: AW: {} Matrixformel mit Strg+Umschalt+Enter abschließe von: Manfred
Geschrieben am: 05.08.2014 12:35:26

Hallo Robert,

ich weis nicht was ich gedacht habe, jetzt funzt es.

Besten dank.

Gruß
Manfred


  

Betrifft: Formel entsprechend abschließen ... von: neopa C (paneo)
Geschrieben am: 05.08.2014 12:29:45

Hallo Manfred.

... beachte untenstehenden Hinweis für den Eingabeabschluß:

 BCDEFGHIJKL
519122 v33 v4 v78910 v
619          

Formeln der Tabelle
ZelleFormel
B5{=SUMME(WENN(ISTZAHL(FINDEN("v";C5:L5)); --WECHSELN(C5:L5;"v";"")))}
B6{=SUMME(WENN(ISTZAHL(FINDEN(" ";C5:L5)); LINKS(C5:L5;FINDEN(" ";C5:L5))*1))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: Formel entsprechend abschließen ... von: Manfred
Geschrieben am: 05.08.2014 12:38:29

Hallo Werner,

suppi, es funzt.

Vielen Dank.

Gruß
Manfred


  

Betrifft: AW: Zellen mit Zahl und Text summieren von: Hajo_Zi
Geschrieben am: 05.08.2014 12:30:38

Hallo Manfred,

Beitrag komplett lesen. Du hast den Text unter der Tabelle nicht beachtet.
Ich würde nach " V" Suchen.

Gruß Hajo


  

Betrifft: AW: Zellen mit Zahl und Text summieren von: Manfred
Geschrieben am: 05.08.2014 12:40:01

Hallo Hajo,

ja du hast recht. Aber jetzt funzt alles.

Recht herzlichen Dank.

Gruß
Manfred


 

Beiträge aus den Excel-Beispielen zum Thema "Zellen mit Zahl und Text summieren"