Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis aus geschlossener Mappe gibt #Wert

Betrifft: Sverweis aus geschlossener Mappe gibt #Wert von: Thorben
Geschrieben am: 07.08.2014 08:13:25

Hallo und guten Morgen alle zusammen,

ich brauch mal kurz Licht ans Fahrad:

Mit folgender Formel (die ich in Spalte G der Zielmappe runterkopiere)
möchte ich Anhand des Abgleichs mit Spalte A die Zahl aus Spalte I aus LHD ausgeben.

Das ganze soll passieren ohne die LHD zu öffnen.

Ich bekomme aber nur #Wert zurück und wenn ich die LHD öffne dann gehts!?

  • =WENN(ZÄHLENWENN('H:\Pfad\Pfad\Pfad\Pfad\Pfad\[AutoImport.xlsx]LHD'!A:A;A2);0;SVERWEIS(A2;'H:\Pfad\Pfad\Pfad\Pfad\Pfad\[AutoImport.xlsx]LHD'!A:I;9;0))


  • Beide Dateien liegen auf dem gleichen Laufwerk!

    Was mach ich falsch?

    Danke und Gruß
    Thorben

      

    Betrifft: AW: Sverweis aus geschlossener Mappe gibt #Wert von: Hajo_Zi
    Geschrieben am: 07.08.2014 08:16:12

    Hallo Torben,

    nicht Sverweis sondern Zählenwenn() braucht eine Offene Datei.

    GrußformelHomepage


      

    Betrifft: gibts da ne Möglichkeit? von: Thorben
    Geschrieben am: 07.08.2014 08:26:23

    ah ok, das hab ich nicht gewußt.

    Gibt es da ne Möglichkeit es trotzdem aus der geschlossenen zu lesen?

    Danke und Gruß
    Thorben


      

    Betrifft: AW: Summenprodukt von: Hajo_Zi
    Geschrieben am: 07.08.2014 09:10:08

    Hallo Torben,

    =SUMMENPRODUKT(('F:\[140807.xlsm]Werte'!$A$1:$A$16>3)*1)
    

    Gruß Hajo


      

    Betrifft: Wow, Danke! owT von: Thorben
    Geschrieben am: 07.08.2014 09:46:14

    .


     

    Beiträge aus den Excel-Beispielen zum Thema "Sverweis aus geschlossener Mappe gibt #Wert"