Microsoft Excel

Herbers Excel/VBA-Archiv

Anzahl bestimmter Werte

Betrifft: Anzahl bestimmter Werte von: Kristina
Geschrieben am: 07.08.2014 15:23:51

hallo,

ich will aus einer Spalte die Anzahl bestimmter Werte zählen. z.B. 160, 400 und 1000.
Die Summer der drei Werte soll mir angezeigt werden.
Danke
Kristina

  

Betrifft: AW: Anzahl bestimmter Werte von: AndreasG
Geschrieben am: 07.08.2014 16:09:10

Hallo Kristina,

=ZÄHLENWENN(A1:A7;"160")+ZÄHLENWENN(A1:A7;"400")+ZÄHLENWENN(A1:A7;"1000")

deinen Suchberich A1:A7 musst du noch anpassen

Grüße
Andreas


  

Betrifft: AW: Anzahl bestimmter Werte von: Thorsten_Z
Geschrieben am: 07.08.2014 16:18:09

Hallo Kristina,

=SUMME((ZÄHLENWENNS($A$2:$A$21;C2)*C2);ZÄHLENWENNS($A$2:$A$21;C3)*C3;ZÄHLENWENNS($A$2:$A$21;C4)*C4) 
Die Formel geht davon aus, dass deine Zahlen in A2 bis A21 stehen (ggf. anpassen), und die drei gesuchten Zahlen in C2 bis C4 stehen.

Gruß
Thorsten


  

Betrifft: AW: Anzahl bestimmter Werte von: Matze Matthias
Geschrieben am: 07.08.2014 16:18:56

Hallo Kristina,
so gemeint das für Jede Zahl die Summe gebildet wird?




Tabelle1

 ABC
1'wert'gesuchter Wert'Summe
2100160960
32004001200
430010003000
5160   
6400'Sum Total5160
7160   
8400   
9100   
10123   
11160   
12100   
131000   
141000   
15100   
16200   
17160   
18160   
19160   
20400   
211000   

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C2:C4=SUMMENPRODUKT((A1:A21=$B2) *$B2)   =SUMPRODUCT((R[-1]C[-2]:R[19]C[-2]=RC2) *RC2)
C6=SUMME(C2:C5)   =SUM(R[-4]C:R[-1]C)

XHTML Tabelle für Darstellung in Foren,
einschl. Bedingter Formatierung ab Version 2007
XHTML-Version 11.50 einschl 64 Bit Version




Formel in C2 eintragen und nach unten kopieren,
geht auch mit Zählenwenn wie Andreas schon schrieb, anstelle "160" dann die Zelle B2 mit dm wert angeben.
Matze


  

Betrifft: gesucht war die Summe der Anzahl .... von: neopa C (paneo)
Geschrieben am: 07.08.2014 16:40:06

allo Matze,

... aber sowohl das als auch die echte Summe geht mit SUMMENPRODUKT() ohne Hilfsformeln.
Sollten die gesuchten Werte auch in einer Spalte stehen, dann allerdings mit {=SUMME(MTRANS()))} )

 ABCDEFG
1Werte  gesuchte Werte
2100  1604001000 
3200      
4300  Anzahl:12  
5160  Summe:5160  
6400      
7160      
8400      
9100      
10123      
11160      
12100      
131000      
141000      
15100      
16200      
17160      
18160      
19160      
20400      
211000      
22       

Formeln der Tabelle
ZelleFormel
E4=SUMMENPRODUKT((A1:A99=D2:Z2)*(A1:A99<>""))
E5=SUMMENPRODUKT((A1:A99=D2:Z2)*D2:Z2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: AW: Anzahl bestimmter Werte von: Kristina
Geschrieben am: 08.08.2014 09:53:03

danke Euch allen, der erste Tip war schon der richtige, aber die anderen sind auch gut zu wissen, so ähnlich hatte ich es auch schon versucht. Aber eben nur so ähnlich :-)
Gruß und schönes Wochenende
Kristina


 

Beiträge aus den Excel-Beispielen zum Thema "Anzahl bestimmter Werte "