Microsoft Excel

Herbers Excel/VBA-Archiv

Fehler in Formel

Betrifft: Fehler in Formel von: Burghard
Geschrieben am: 14.08.2014 23:46:38

Hallo,

meine untere Formel funktioniert nicht ganz richtig.

=WENN(A3="";"";SUMME(C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"")*ZEILE(C1:C25)))))-C2) /E2*1000

Wenn A3 leer ist, dann wird in der Berechnungszelle F2 "#Wert" angezeigt. Schreibe ich nur =WENN(A3="";"") bleibt die Berechnungszelle F2 leer, das Problem steckt also in dem Teil "Summe ...".
In der Zelle F3 (und den anderen Zellen darunter) steht eine Formel zur Berechnung: =WENN(E3="";"";SUMME(C3/E3)*1000).
Wie kann ich #Wert in der Zelle F2 unterdrücken? Mit der Wiederholung der Formel hat es bei mir nicht geklappt.

=WENN(ISTFEHLER(SUMME(C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"")*ZEILE(C1:C25)))))-C2) /E2*1000;0;SUMME(C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"")*ZEILE(C1:C25)))))-C2) /E2*1000

Hilfe wäre nett.

Grüße Burghard

  

Betrifft: Lad die Mappe hoch... oT von: {Boris}
Geschrieben am: 14.08.2014 23:50:39

VG, Boris


  

Betrifft: AW: Mappe von: Burghard
Geschrieben am: 15.08.2014 00:27:33

Hallo Boris,

hab die Mappe hochgeladen.

https://www.herber.de/bbs/user/92124.xls

Grüße Burghard


  

Betrifft: AW: du musst.... von: hary
Geschrieben am: 15.08.2014 06:56:34

Moin
..den letzten Teil in die Klammer setzen.



Auto-Ölverbrauch

 F
2 

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
F2=WENN(A3="";"";SUMME((C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"")*ZEILE(C1:C25)))))-C2)/E2*1000)  =IF(R[1]C[-5]="","",SUM((RC[-3]:INDEX(R[-1]C[-3]:R[23]C[-3],SUMPRODUCT(MAX((R[-1]C[-3]:R[23]C[-3]<>"")*ROW(R[-1]C[-3]:R[23]C[-3])))))-RC[-3])/RC[-1]*1000)

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: Fehler in Formel von: Bernd
Geschrieben am: 15.08.2014 04:46:45

Hallöchen!

Das geht mit bedingter Formatierung, dort die Formel

~=ISTFEHLER(F2~

rein und die Schriftart mit WEISS formatieren.

(siehe Beispiel) https://www.herber.de/bbs/user/92125.xls


Bin kein Profiexcelianer und hoffe, es hilft Dir weiter. Mir wurde hier immer geholfen,
und ich will dazu lernen, und helfe auch anderen.

lg aus Klagenfurt wünscht

Bernd


  

Betrifft: AW: Fehler in Formel von: Bernd
Geschrieben am: 15.08.2014 04:47:36

Formel natürlich so:

~=ISTFEHLER(F2)~


  

Betrifft: AW: Lösung! von: Burghard
Geschrieben am: 15.08.2014 11:07:55

Hallo Leute,

vielen Dank für die Antworten/Hilfen. Damit konnte ich mir die Lösung basteln:

=WENN(A3="";"";WENN(ISTFEHLER(F3)*(SUMME(C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"") *ZEILE(C1:C25)))))-C2)/E2*1000;0;SUMME(C2:INDEX(C1:C25;SUMMENPRODUKT(MAX((C1:C25<>"") *ZEILE(C1:C25)))))-C2)/E2*1000)

Dank an alle!

Gruß Burghard


 

Beiträge aus den Excel-Beispielen zum Thema "Fehler in Formel"