Microsoft Excel

Herbers Excel/VBA-Archiv

mittelwertwenns

Betrifft: mittelwertwenns von: Ich_halt
Geschrieben am: 15.08.2014 10:51:42

Hallo,

ich habe folgende Übersicht:

A B C D E F
Datum Name1 Name2 Name3 Name2 Name1
01.01. 12 4 8 3 15
02.01. 13 12 11 7 16
03.01. 9 5 9 7 11

Wie kann ich jetzt für einen bestimmten Namen zu einem bestimmten Tag den Mittelwert berechnen lassen?

Vielen Dank im Voraus.

Grüße,
Ich_halt

  

Betrifft: AW: mittelwertwenns von: Hajo_Zi
Geschrieben am: 15.08.2014 10:58:56

ein Klasse Beispiel. Es braucht kein Mittelwert gebildet werden, da nur ein Datensatz je Name.

Ich baue keine Datei nach, die Zeit hat schon jemand investiert.
Ein Nachbau sieht bestimmt anders aus als das Original.
Ein Link zur Datei oder ein Tabellen Ausschnitt nicht als Bild wäre nicht schlecht.

Jul 2014

 C
29Falsch
30496

verwendete Formeln
Zelle Formel Bereich N/A
C29=C27=C28  
C30=SUMMEWENN([Bildschirm.xlsm]Statistik!$Q$44:$Q$54;"<" &HEUTE();[Bildschirm.xlsm]Statistik!$R$54)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.07 einschl. 64 Bit


Benutze hier im Forum die Funktion zum hochladen. Falls Du die nicht benutzen möchtest beachte, von unsicheren Servern wie z.B. www.file-upload.net lade ich keine Datei runter. (lt. Einschätzung meines Virenprogramms)
Der Dateiname sollte was mit dem Problem zu tun haben.
Ich habe mir z.B. einen Ordner angelegt in dem ich alle Dateien aus dem Internet speichere. Bei Dateinamen wie Test..., Mappe…, Beispiel… wird eine vorhandene überschrieben.
Ein Bild in Excel geöffnet sieht anders aus als das Bild.
Ich habe kein Tool um ein Bild in Excel zu importieren.

GrußformelHomepage


  

Betrifft: Schau nochmal hin, Hajo ... von: Klaus M.vdT.
Geschrieben am: 15.08.2014 11:04:37

... "Name1" kommt zweimal vor! "Name2" auch.
Davon ab lässt sich auch für "Name3" ein gültiger Mittelwert bilden. Macht halt keinen Sinn.

Grüße,
Klaus M.vdT.


  

Betrifft: AW: mittelwertwenns von: Klaus M.vdT.
Geschrieben am: 15.08.2014 11:03:08

Hallo, ich spreche meine Gegenüber gerne mit Realnamen an. Deiner ist?

Wenn du keine Mustertabelle hochlädst, mach ichs auch nicht!
A B C D E F G H I J
Name1 Name2 Name3 Name2 Name1 Name: Name1
01. Jan 12 4 8 3 15 Datum: 02. Jan
02. Jan 13 12 11 7 16 Mittelwert: 14,5
03. Jan 9 5 9 7 11

=SUMMEWENN(B1:F1;I1;BEREICH.VERSCHIEBEN(B1:F1;-1+VERGLEICH(I2;A:A;);0;))/ZÄHLENWENN(B1:F1;I1)

(Unten ist der File-Upload Button. Ne echte Tabelle währ doch viel lesbarer, oder?

Grüße,
Klaus M.vdT.


  

Betrifft: AW: mittelwertwenns von: Ich_halt
Geschrieben am: 15.08.2014 11:10:14

Hallo Klaus,

Deine Lösung ist klasse und funktioniert einwandfrei :) Das nächste Mal lade ich eine Beispieldatei hoch, versprochen.

Lg,
Susanne


  

Betrifft: AW: mittelwertwenns von: Ich_halt
Geschrieben am: 15.08.2014 11:11:05

Danke - hab ich vergessen :)


  

Betrifft: Danke für die Rückmeldung! mT. von: Klaus M.vdT.
Geschrieben am: 15.08.2014 11:26:09

Hallo Susanne,
freut mich geholfen zu haben!
Viele Grüße,
Klaus M.vdT.