Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für "enthält nicht"

Betrifft: Formel für "enthält nicht" von: Miri
Geschrieben am: 01.09.2014 13:13:26

Hallo,

ich möchte bei meiner Datei die Gesamtanzahl der bestellten Waren zusammenzählen, jedoch sollen Werte oder Texte die das Zeichen # enthalten nicht brücksichtigt werden..
Hier mal ein Beispiel
Spalte A-------------Spalte B-----------Spalte C
Name der Ware-------Anzahl---------------Gesamtanzahl
Apfel----------------------1--------------------??
Birne----------------------2
Apfel----------------------5
#Apfel----------------------3

Also soll in Spalte C die Summe der bestellten Äpfel und Birnen rauskommen, jedoch ohne die 3 Äpfel am Ende (= 8)

Schonmal vielen Dank für eure Hilfe
Liebe Grüße Miri

  

Betrifft: AW: Formel für "enthält nicht" von: yummi
Geschrieben am: 01.09.2014 13:23:00

Hallo Miri,

das geht mit SummeWenn

In C2
=SUMMEWENN(A2:A5;A2;B2:B5)
In C3
=SUMMEWENN(A2:A5;A3;B2:B5)

ist allerdings Ungetestet

Gruß
yummi


  

Betrifft: =SUMMEWENN(A2:A5;"<>#*";B2:B5) owT von: Rudi Maintaire
Geschrieben am: 01.09.2014 13:23:16




  

Betrifft: AW: Formel für "enthält nicht" von: Daniel
Geschrieben am: 01.09.2014 13:25:21

Hi

=SummeWenn(A:A;"<>#*";B:B)

Gruß Daniel


  

Betrifft: AW: Formel für "enthält nicht" von: Miri
Geschrieben am: 01.09.2014 13:35:39

Super, vielen Dank euch!
Mit <>"#*" klappts perfekt

Schönen Tag euch noch


  

Betrifft: AW: Formel für "enthält nicht" von: Miri
Geschrieben am: 01.09.2014 13:36:51

Ich meinte natürlich mit "<>#*"


 

Beiträge aus den Excel-Beispielen zum Thema "Formel für "enthält nicht""