Microsoft Excel

Herbers Excel/VBA-Archiv

Summe über variablen Teilbereich

Betrifft: Summe über variablen Teilbereich von: Smisma Smeidl
Geschrieben am: 05.09.2014 12:31:41

Moin moin,

ich sitze den gesamte Vormittag an folgendem Problem:

Eine Spalte mit Werten die um 0 schwanken, nun möchte ich die Summe jedes Schwingers ermitteln.

Also als Beispiel:

Spalte1 Spalte2
0,11298
0,14340
0,11423
0,06215 0,43276 (Summe aus Zeile 1 bis 4)
-0,02132
-0,10507
-0,12674
-0,05243 -0,30557 (Summe aus Zeile 5 bis 8)
0,05854
0,11673
0,13132
0,11673
0,06645
0,01409 0,50386 (Summe Zeile 9 bis 14)
-0,01882
-0,01993 -0,03876 (Summe Zeile 15 bis 16)
0,03118
0,06757
0,07659
0,08979
0,09507
0,07757
0,03826 0,47601 (Summe Zeile 17 bis 23)

Gibts ne Formel in Spalte 2 die ich einfach nur runterziehen kann???

MfG,
Smisma Smeidl

  

Betrifft: AW: Summe über variablen Teilbereich von: Hajo_zi
Geschrieben am: 05.09.2014 12:53:12

Hallo Smisma,


Tabelle2

 AB
10,11298 
20,1434 
30,11423 
40,062150,43276
5-0,02132 
6-0,10507 
7-0,12674 
8-0,05243-0,30556
90,05854 
100,11673 
110,13132 
120,11673 
130,06645 
140,014090,50386
15-0,01882 
16-0,01993-0,03875
170,03118 
180,06757 
190,07659 
200,08979 
210,09507 
220,07757 
230,03826 

verwendete Formeln
Zelle Formel Bereich N/A
B2:B23=WENN(ODER(UND(A2>0;A3<0);UND(A2<0;A3>0));SUMME($A$1:A2)-SUMME($B$1:B1);"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.13 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Summe über variablen Teilbereich von: Smisma Smeidl
Geschrieben am: 05.09.2014 13:05:02

Wow! Gutes kann so einfach sein ^^.

Danke für die schnelle und einfache Lösung. Manchmal hat man echt n Brett vorm Kopf wenn man zu lange über nem Problem sitzt...


  

Betrifft: AW: Summe über variablen Teilbereich von: Smisma Smeidl
Geschrieben am: 05.09.2014 13:17:35

Wow! Gutes kann so einfach sein ^^.

Danke für die schnelle und einfache Lösung. Manchmal hat man echt n Brett vorm Kopf wenn man zu lange über nem Problem sitzt...


 

Beiträge aus den Excel-Beispielen zum Thema "Summe über variablen Teilbereich"