Microsoft Excel

Herbers Excel/VBA-Archiv

Warum gibt meine Formel einen Fehler aus?

Betrifft: Warum gibt meine Formel einen Fehler aus? von: Christian
Geschrieben am: 07.09.2014 10:51:33

Hallo an alle,

bitte helft mir. Ich versuche so etwas zu basteln wie

=WENN(A1<>eine der Zahlen in B1:B11;ZUFALLSZAHL();"")

sodass ich die Formel von C1 bis C22 kopieren kann.

Ich habe es mit der Formel

=WENN(A1<>B$1:B$11;ZUFALLSZAHL();"")

probiert, bis C11 funktioniert sie auch, aber ab C12 gibt sie nur #WERT! aus.

Was mache ich falsch?
Gruß und danke
Christian

  

Betrifft: AW: Warum gibt meine Formel einen Fehler aus? von: Hajo_Zi
Geschrieben am: 07.09.2014 11:05:42

Hallo Christian,

ich bin nicht der Formelmensch. Ich würde vermuten da Du ein Array prüfst, solltest Du die Formel auch entsprechend eingegeben.

Tabelle2

 C
1 
26,33009365664294E-02
3 
4 
5 
6 
7 
8 
9 
10 
11 
12 
13 

verwendete Formeln
Zelle Formel Bereich N/A
C1:C13{=WENN(A1<>B$1:B$11;ZUFALLSZAHL();"")}$C$1 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.14 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Warum gibt meine Formel einen Fehler aus? von: Christian
Geschrieben am: 07.09.2014 11:07:13

Hallo Hajo,

ich probier es mal.

Was ich will, ist folgendes,

steht A1 irgendwo im Bereich B1:B11 lass die Zelle leer, ansonsten gebe eine Zufallszahl aus.

Gruß
Christian


  

Betrifft: AW: Warum gibt meine Formel einen Fehler aus? von: Hajo_Zi
Geschrieben am: 07.09.2014 11:13:26

Hallo Christian,

ich hätte ja Zählenwenn() benutzt.

Tabelle2

 ABC
1  0,113083140265601
21  
3 10,779296568589816
4  0,834609171773097
5  0,252387915071051
6  0,717586062232826
7  0,121097138549503
8  0,380558290771437
9  6,91293044535163E-02
10  0,428899818506962
11  0,601909674080958
12  0,207052726548535
13  8,87286379160365E-02

verwendete Formeln
Zelle Formel Bereich N/A
C1:C13=WENN(ZÄHLENWENN(B$1:B$11;A1)=0;ZUFALLSZAHL();"")  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.14 einschl. 64 Bit



Gruß Hajo


  

Betrifft: AW: Warum gibt meine Formel einen Fehler aus? von: Christian
Geschrieben am: 07.09.2014 11:16:08

Hallo Hajo,

danke für den Tipp mit Zählenwenn, so funktioniert es. Aber ich bin nunmal was das anbelangt Laie, der sich irgendwie zu behelfen versucht. Bin halt von selbst nicht auf diese Idee gekommen.

Danke
Christian


  

Betrifft: AW: Warum gibt meine Formel einen Fehler aus? von: Christian
Geschrieben am: 07.09.2014 11:14:31

Hallo Hajo,

die Formel {=WENN(A1=B$1:B$11;"";ZUFALLSZAHL())}

genauso wie

{=WENN(A1<>B$1:B$11;ZUFALLSZAHL();"")}

lassen bei mir nur eine einzige Zelle leer und zwar entsprechend der Zahl die in B1 steht.

also wenn in B1 die 7 steht, gibt {=WENN(A7=B$1:B$11;"";ZUFALLSZAHL())} eine leere Zelle aus.
Allerdings {=WENN(A14=B$1:B$11;"";ZUFALLSZAHL())} gibt eine Zufallszahl aus, obwohl in B2 die 14 steht.

Zur Info in A1:A22 stehen die Zahlen von 1 bis 22.

Gruß
Christian


 

Beiträge aus den Excel-Beispielen zum Thema "Warum gibt meine Formel einen Fehler aus?"