Microsoft Excel

Herbers Excel/VBA-Archiv

Urlaubs und Personalplanung verknüpfen

Betrifft: Urlaubs und Personalplanung verknüpfen von: Kalli
Geschrieben am: 17.09.2014 20:53:30

Hallo zusammen,
ich brüte gerade über einer Personal- und Urlaubsplanung ( für 28 Personen).
Die Personalplanung ist eine Wochenplanung.
Nun möchte ich gerne die Urlaubsplanung in die Wochenplanung integrieren.

Wochenplanung:(Plan)

A6 Montag B6 Kim
A7 04.08.2014 B7 Sabine
A8 -Leer- B8 Adelheid
usw.
A34 Dienstag gleiche Namen wie B6 ....
A35 05.08.2014

Der Urlaubsplaner ist monatlich.

Das Datum beginnt in F5
Der Name der MA steht ab B10.

Ich habe noch keinen Lösungsansatz gefunden, wie ich das Datum in Zeile =Plan! A7 mit den 12 Monatsblättern der Urlaubsplanung vergleichen kann und wenn da ein Wert drinsteht, diesen zu übernehmen.

Ich bin für jeden Lösungsansatz dankbar

mfg

kalle

  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: Daniel
Geschrieben am: 17.09.2014 21:03:08

HI
wenn du den Urlaubsplan für auf einem Blatt für ein ganzes Jahr darstellst, wird die Sache viel einfacher.
Sowohl zum auswerten, als auch zum Eingeben.

Excel hat mittlerweile mehr als 256 Spalten, so dass du problemlos ein ganzes Jahr Tagesgenau mit Zusatzdaten nebeneinander darstellen kannst.

Gruß Daniel


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: Kalli
Geschrieben am: 17.09.2014 21:37:47

Hallo Daniel,
somit müsste ich den Urlaubsplan komplett neu erstellen.
Auch wenn das Aufwendinger ist würde ich gerne bei der monatlichen Variante bleiben.

Aber wenn es sein muss, dann werde ich das mal umsetzen und eine Jahresübersicht basteln.

mfg
kalli


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: Kalli
Geschrieben am: 17.09.2014 22:30:13

Hat noch jemand eine Idee ?

mfg
kalli


  

Betrifft: 12 Monatsblätter geht auch ... von: Matthias L
Geschrieben am: 18.09.2014 00:47:06

Hallo

Hier auszugsweise eine ganz einfache Variante:

 ABCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAF
1Januar 201501020304050607080910111213141516171819202122232425262728293031
2Mitarbeiter1UU  UUUUU                      
3Mitarbeiter2                               
4Mitarbeiter3                               
5Mitarbeiter4                               
6Mitarbeiter5           UUUUU               
7Mitarbeiter6                               


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Natürlich sind in Zeile(1) Formeln zur automatischen Anpassung der Wochentage (WE).

Januar

 ABCDEFGHIJ
1Januar 2015010203040506070809

Formeln der Tabelle
ZelleFormel
B1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
C1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
D1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
E1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
F1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
G1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
H1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
I1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")
J1=WENNFEHLER(DATWERT(VERKETTEN(SPALTE()-1;LINKS($A$1;LÄNGE($A$1)-5);RECHTS($A$1;4)));"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4





Hier mal eine einfache BspDatei zum "spielen"

https://www.herber.de/bbs/user/92696.xlsx

Der Januar ist mal etwas anders dargestellt als die anderen Monate

Gruß Matthias


  

Betrifft: AW: 12 Monatsblätter geht auch ... von: Kalli
Geschrieben am: 18.09.2014 16:49:41

Hallo Matthias,
danke für die "Spieldatei".
Aber ich habe bereits eine Wochenplanung und einen Urlaubsplaner.
Nun möchte ich den Urlaub in die Wochenplanung übernehmen.
Damit du die ein Bild machen kannst habe ich in deiner Datei mal ein Blatt "Plan" eingefügt und den Januar auf meinen Urlaubsplan geändert.

https://www.herber.de/bbs/user/92714.xlsx

mfg
kalle


  

Betrifft: AW: 12 Monatsblätter geht auch ... von: Daniel
Geschrieben am: 18.09.2014 17:20:15

Hi

wenn du die Urlaubsplanung in einem Blatt für das ganze Jahr erstellst, dann kannst du mit einfachen Formeln im Plan abfragen, ob der austwählte Mitarbieter grad Urlaub hat oder nicht.

Gruß Daniel

https://www.herber.de/bbs/user/92716.xlsx


  

Betrifft: und nun ? von: Matthias L
Geschrieben am: 19.09.2014 01:14:53

Hallo


Dein letzter Beitrag war: Hat noch jemand eine Idee ?
Ok, die hatte ich!

Aber mit Deinem Blatt "Plan" kann ich nicht so recht was anfangen.

Gruß Matthias


  

Betrifft: AW: und nun ? von: kalli
Geschrieben am: 19.09.2014 17:53:22

@ Matthias:
Du musst nicht gleich laut werden. Nur weil ich nicht ab 01:14 Uhr geantwortet habe.
Und mein letzter Beitrag war "Hallo Matthias, Danke für die "Spieldatei"" nur so nebenbei.
Deine Datei beinhaltet nur einen Urlaubsplan.
Zum Verständniss:
Das Blatt "Plan" ist die Wochenplanung der MA. In der Spalte B stehen die Namen der Mitarbeiter (1 bis 28).
Ab der Spalte D sind die Uhrzeiten, zu denen der MA verplant werden soll.
Wenn nun ein MA Urlaub hat, so sollte das in den "Plan" übernommen werden.
Das Blatt "Plan" ist nur ein Ausschnitt aus dem Original. Geht logischer Weise von Montag bis Freitag.
Im hinteren Teil werden noch einige Berechnungen durchgeführt, die ich hier aber nicht eingefügt habe.
Der Vorschlag von Daniel geht schon in die richtige Richtung, schöner wäre eine Lösung über 12 Monatsblätter, da es im Urlaubsplan noch einige Blätter gibt, die mir wichtig sind.

@ Daniel:
danke erstmal. Das muss ich mir nochmal sehr genau ansehen ob das umsetzbar ist.


  

Betrifft: AW: und nun ? von: Matthias L
Geschrieben am: 19.09.2014 20:23:13

Hallo

Zitat

Du musst nicht gleich laut werden. Nur weil ich nicht ab 01:14 Uhr geantwortet habe.

Wer hat denn das gefordert / erwartet. Ich nicht. Was soll das denn jetzt?



Nur weil ich mit Deiner Datei nichts anfangen kann und ich Dir das mitgeteilt habe musst Du Dich mir
gegenüber jetzt nicht so unschön äußern. Ich hab Dir nichts getan, wollte Dir nur helfen!

Gruß Matthias


  

Betrifft: AW: und nun ? von: kalli
Geschrieben am: 20.09.2014 12:59:46

Hallo Matthias,

nur für den Fall dass du es nicht weißt, aber wer in Foren Fett schreibt, der ist laut.

Das kam bei mir nicht so gut an, denn ich musste ja erstmal deinen und Daniel´s Vorschläge mir anschauen und versuchen zu verstehen was ihr da gemacht habt.
Ich kenne mich leider mit Formeln, Funktionen, Macros und VBA nicht so gut aus wie Ihr deshalb dauert das etwas länger.
Und das du mit dem "Plan" nichts anfangen konntest kann ich mir vorstellen. Da habe ich euch wohl zu wenig Infos gegeben, was ich überhaupt vorhabe.

mfg
kalli


  

Betrifft: Nee, nee, so nicht ... von: Matthias L
Geschrieben am: 20.09.2014 19:48:46

Hallo (das ist Fett und nicht laut!)

Zitat:
nur für den Fall dass du es nicht weißt, aber wer in Foren Fett schreibt, der ist laut.
Wer hat Dir das denn eingeimpft?

Willst Du wissen seit wieviel Jahren ich in Foren unterwegs bin?
Mind. 10 Jahre bei Spotlight.de (leider eingestellt)
dannach bei Herber.de

Nur wer alles groß schreibt ist laut! (aber auch nicht zwingend!)
Was meinst Du wohl warum über dem Beitragstext die Button (fett,kursiv,Liste ... etc) zur Verfügung stehen?
Da hast Du wohl was verwechselt.

Wenn Du nun noch was zum Thema erläutern willst, bin ich gern bereit Dir weiter zu helfen.
Ansonsten bin ich aus der Nummer raus.

Gruß Matthias


  

Betrifft: AW: Nee, nee, so nicht ... von: kalli
Geschrieben am: 20.09.2014 20:12:11

Hallo Matthias,
auch ich bin seit über 15 Jahren in diversen Foren unterwegs und weiß ganz genau was es heißt, wenn jemand mehr als ein Wort fett schreibt. Das wurde nicht eingeimpf, sondern ist gängige Praxis.
Wenn das hier im Forum anders ist, dann OK.

Ich hatte ganz deutlich geschrieben:

Zitat:

Ich habe noch keinen Lösungsansatz gefunden, wie ich das Datum in Zeile =Plan! A7 mit den 12 Monatsblättern der Urlaubsplanung vergleichen kann und wenn da ein Wert drinsteht, diesen zu übernehmen.

Bis jetzt habe ich nur von Dir eine Datei, worin ein Urlaubsplan steht.
Den habe ich aber schon.

Daniel war da schon weiter und hat zumindest einen Lösungsansatz gefunden.
Wenn dieser nun noch die Abfrage über 12 Monatsblätter beinhaltet, dann ist alles klar.

mfg
kalli


  

Betrifft: ... nachgedacht von: Matthias L
Geschrieben am: 20.09.2014 20:54:25

Hallo

Ok ...

Zitat
Bis jetzt habe ich nur! (das ist viel abwertender als fett! )von Dir eine Datei, worin ein Urlaubsplan steht.

Scheinst ja nicht begriffen zu haben das ich explizit nur für Dich die Datei erstellt habe
und das man ein Problem nur Step by Step löst.

Aber Du musst ja meine Datei gleich so verändern, das Andere denken ich hätte das so geschickt.
Warum sollte bei mir denn der Januar erst m 5. beginnen?
Nee, nee das warst Du selbst!

 ABCDEFGHIJ
1Januar 2015         
2         
3          
4          
5     MoDiMiDoFr
6     0506070809
7          
8          
9Pers.-Nr.Name  Resturlaub     
10 Mitarbeiter1   UU  U
11 Mitarbeiter2        


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Das habe ich Dir so nicht geschickt!
Wenn Du es schon so benutzen willst musst Du die Formeln anpassen.
Und wenn Du etwas nicht verstehst kannst Du ja fragen.

 ABCDEFGHIJKLMNOP
1Januar 2015               
2               
3                
4                
5     DoFrSaSoMoDiMiDoFrSaSo
6     0102030405060708091011
7                
8                
9Pers.-Nr.Name  Resturlaub           
10 Mitarbeiter1   UU  UUUUU  
11 Mitarbeiter2              
12 Mitarbeiter3              


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Aber ich habe jetzt keine Lust mehr Dir zu helfen.

Gruß Matthias


  

Betrifft: AW: ... nachgedacht von: kalli
Geschrieben am: 20.09.2014 22:04:12

Hallo Matthias,

dann lass es eben bleiben.
Du bist voll daneben. Ein Urlaubsplaner war gar nicht angrfragt.
Sondern die Möglichkeit aus 12 Blättern ein Datum herauszusuchen und das in einem anderen Blatt anzuzeigen.
Warum du jetzt auf deinem Urlaubsplan rumreitest ist mir schleierhaft.

Du solltest die Postings wohl mal richtig durchlesen bevor du antwortest.

gefragt war folgendes:

Ich habe noch keinen Lösungsansatz gefunden, wie ich das Datum in Zeile =Plan! A7 mit den 12 Monatsblättern der Urlaubsplanung vergleichen kann und wenn da ein Wert drinsteht, diesen zu übernehmen.


Zu der Netiquette solltest du mal folgendes lesen:

Zitat:

Das andauernde Schreiben in GROSSBUCHSTABEN oder andauernde Fettschrift gilt nicht nur als unschön, sondern wird in der Regel als aggressives Schreien interpretiert und sollte daher unterbleiben.

Quelle:
http://de.wikipedia.org/wiki/Netiquette

Auch mir reicht es jetzt.


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: kalli
Geschrieben am: 21.09.2014 16:49:14

Hallo Daniel,
ich habe deinen Vorschlag umgesetzt.
Klappt gut.
Danke

mfg
kalli


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: kalli
Geschrieben am: 21.09.2014 17:03:17

Hallo Daniel,
kann ich auch einen Platzhalter für den 29.02. einfügen?
Somit wären alle Jahre abgedeckt und ich müsste nicht alle 4 Jahre manuell einen 29. einfügen.

mfg
kalli


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: Daniel
Geschrieben am: 21.09.2014 17:13:21

Hi
Warum sollte man das?
Jede Zelle ist ein Tag weiter.
Ob da spielst keine Rolle, ob jetzt ist Schaltjahr oder nicht.

Gruß Daniel


  

Betrifft: AW: ein Jahresblatt statt 12 Monatsblätter von: kalli
Geschrieben am: 21.09.2014 17:37:59

Sorry Daniel,
ich habe vergessen, die Formel zur Berechnung der Tage zu ändern.
Die stammten noch aus den Monatsblättern.
Somit hat sich das erübrigt.
Vielen Dank nochmal für die Hilfe,
jetzt klappe es genau so, wie ich es haben wollte. :-)

mfg
kalli


 

Beiträge aus den Excel-Beispielen zum Thema "Urlaubs und Personalplanung verknüpfen"