Microsoft Excel

Herbers Excel/VBA-Archiv

Stringsuche

Betrifft: Stringsuche von: Andreas
Geschrieben am: 30.09.2014 14:42:31

Hallo, für euch wohl sehr rudimentär....

Ich möchte wissen, ob ein teil der nummer von spalte A (sheet abfrage) in der Liste (Sheet Test) vorhanden ist, und das Resultat "ja / nein" in Spalte B des sheets abfrage ausgeben.

Kann mir jemand helfen?

https://www.herber.de/bbs/user/92913.xlsx

  

Betrifft: AW: Stringsuche von: {Boris}
Geschrieben am: 30.09.2014 15:25:39

Hi Andreas,

B2:
=WENN(ZÄHLENWENN(test!A:A;RECHTS(A2;9));"ja";"nein")
und runterkopieren.

VG, Boris


  

Betrifft: kleine Arrayformel, wenn ... von: WF
Geschrieben am: 30.09.2014 15:39:30

... die Testzahlen auch kleiner als 9-stellig sein können:
{=WENN(ANZAHL(SUCHEN(test!A$1:A$235;A2)*1);"ja";"nein")}

Salut WF


  

Betrifft: Nein... von: {Boris}
Geschrieben am: 30.09.2014 15:49:34

Hi Walter,

das geht in die Hose, da dann für die Zahl 123456789 auch die Vergleichzahl 789 ein Treffer wäre.

VG, Boris


  

Betrifft: genau so meinte ich es ja von: WF
Geschrieben am: 30.09.2014 15:56:13

auch die Zahl 3456 ist ein Treffer

WF


  

Betrifft: OK - nach "enthält" - dann wär`s passend... von: {Boris}
Geschrieben am: 30.09.2014 16:00:52

VG, Boris


  

Betrifft: AW: OK - nach "enthält" - dann wär`s passend... von: Andreas
Geschrieben am: 01.10.2014 08:41:54

- bei der Formel von Boris kriege ich immer ein nein, jener von WF immer ein Wahr :(
Irgendetwas scheint noch nicht korrekt zu funktionieren..

Wäre die Lösung auch mit einem SVerweis möglich?


  

Betrifft: AW: OK - nach "enthält" - dann wär`s passend... von: {Boris}
Geschrieben am: 01.10.2014 10:07:59

Hi Andreas,

ARRAY(!)formeln sind mit gleichzeitig Strg+Shift+Enter einzugeben.
Aber nach Deiner Antwort zu urteilen sollte doch meine eingangs gepostete Formel reichen:

=WENN(ZÄHLENWENN(test!A:A;RECHTS(A2;9));"ja";"nein")

VG, Boris


  

Betrifft: AW: Stringsuche von: Bernd
Geschrieben am: 30.09.2014 15:26:59

Hallo Andreas,

vielleicht so:

https://www.herber.de/bbs/user/92914.xlsx

Aber es gibt bestimmt noch eine schlankere Möglichkeit, die mir aber im Moment nicht einfällt.

Viele Grüße
Bernd


  

Betrifft: Bei unterschiedlichen Zahllängen ... von: {Boris}
Geschrieben am: 30.09.2014 15:43:11

Hi Bernd,

reicht dann aber:

B2:
{=WENN(ZÄHLENWENN(test!A:A;RECHTS(A2;ANZAHL(RECHTS(A2;SPALTE($1:$1))*1)));"ja";"nein")}

ARRAY(!)formel.

VG, Boris


  

Betrifft: AW: Stringsuche von: Andreas
Geschrieben am: 01.10.2014 08:01:01

Nun, danke euch. Es ist schon so, dass der komplette Wert einer Zelle im Sheet Test in spalte A (Abfrage enthalten sein muss) enthalten sein muss. Die Zahllänge ist immer gleich, im Original 9 Stellen