Microsoft Excel

Herbers Excel/VBA-Archiv

Fehlermeldung wenn Kriterien

Betrifft: Fehlermeldung wenn Kriterien von: Stan
Geschrieben am: 01.10.2014 15:44:28

Hallo zusammen,

Fragestellung: ich muss 200 Seminare in 50 Städten organisieren.
Es darf kein Seminar zum selben Datum am selben Ort stattfinden.
Deshalb hätte ich gerne eine Fehlermeldung, die mir sagt "Ort schon zu diesem Datum gebucht" wenn ich versehentlich einen doppelt eingebe.

Anbei die Datei:
https://www.herber.de/bbs/user/92932.xlsx

Ich kann den gleichen Termin gleichzeitig in mehreren Städten haben, aber nicht gleichzeitig mehrere Termine in der gleichen Stadt (der Raum ist dann nämlich schon ausgebucht)
Manche Seminare gehen 3 Tage, manche weniger lang, aber sobald ein einziger Termintag für eine Stadt gebucht ist kann kein anderes Seminar zu dem Datum mehr stattfinden.

Ich hoffe ich habe mich verständlich ausgedruckt.

Danke und viele Grüße,

Stan

  

Betrifft: AW: Fehlermeldung wenn Kriterien von: selli
Geschrieben am: 01.10.2014 16:07:24

hallo stan,

ich würde die tabelle ganz anders aufbauen.
eine spalte für die tage des ganzen jahres, für jede stadt eine weitere spalte und in der spalte der stadt in der jeweiligen datumszeile dann das seminar eintragen.

gruß
selli


  

Betrifft: z.B. mit SUMMENPRODUKT() ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 16:24:16

Hallo Stan /Peter,

... und Formel nach unten kopieren:

Tabelle1

 ABCD
1AnfangsdatumEnddatumOrtFormel
201. Jan03. JanMünchenok
303. Feb06. FebBremenok
412. Sep18. SepFrankfurtok
516. Okt17. OktBerlinok
619. Dez23. DezHamburgok
704. Jan07. JanMünchenschon gebucht

Formeln der Tabelle
ZelleFormel
D2=WENN(SUMMENPRODUKT(($C$2:C2=C2)*((A$2:A2<B2)+(B$2:B2<A2)))<2;"ok";"schon gebucht")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit SUMMENPRODUKT() ... von: selli
Geschrieben am: 01.10.2014 16:34:00

hallo werner,

in deinem beispiel ist doch aber gar nichts doppelt gebucht.

die termine in münchen überschneiden sich doch gar nicht.

gruß
selli


  

Betrifft: Korrektur ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 16:55:42

Hallo seli,

... danke das Du aufgepasst hast.

Meine Korrektur (nur grob getestet) sieht so aus:

Tabelle1

 ABCD
1AnfangsdatumEnddatumOrtFormel
201.01.1403.01.14Münchenok
303.02.1406.02.14Bremenok
412.09.1418.09.14Frankfurtok
516.10.1417.10.14Berlinok
619.12.1423.12.14Hamburgok
703.01.1407.01.14Münchenschon gebucht

Formeln der Tabelle
ZelleFormel
D2=WENN(SUMMENPRODUKT(($C$2:C2=C2)*((A$2:A2<=B2)*(B$2:B2>=A2)))<2;"ok";"schon gebucht")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: und noch ein sorry ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 17:05:03

Hallo selli,

... dass ich vorhin Deinen Namen falsch geschrieben habe.


Gruß Werner
.. , - ...


  

Betrifft: Das dürfte so auch OK sein, ... von: Luc:-?
Geschrieben am: 01.10.2014 19:35:08

…Werner,
denn die Fml hat selbst mit meinen etwas raffinierteren Testdaten gut fktioniert. Allerdings kannst du noch 2 Klammern im Wenn-Arg einsparen: SUMMENPRODUKT(($C$2:C2=C2)*(A$2:A2<=B2)*(B$2:B2>=A2))<2
Oder auch so: SUMMENPRODUKT(N($C$2:C2=C2);N(A$2:A2<=B2);N(B$2:B2>=A2))<2
Gruß, Luc :-?


  

Betrifft: Klammerrückstände ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 10:31:04

Hallo Luc,

... das unnütze Klammerpaar hier "stammte" noch der vorherigen ODER-Beziehung, wo es ja zwingend notwendig war. Danke für das Testen.


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Fehlermeldung wenn Kriterien"