Microsoft Excel

Herbers Excel/VBA-Archiv

Dynamischer Tabellenbereich - letzten 12 monate

Betrifft: Dynamischer Tabellenbereich - letzten 12 monate von: D.Henschel
Geschrieben am: 10.10.2014 11:32:41

Hallo,

habe eine Tabelle die ich monatlich um eine Zeile ergänze. Die Daten werden dann in einem anderen Worksheet ausgewertet (letzten 12 Monate).
Bisher machen wir das so: neue Zeile einfügen, letzte löschen

Ich bin mir ziemlich sicher, das geht auch anders aber meine Excel Kenntnisse stoßen da an ihre Grenzen.

Ich habe da was probiert mit MAX / MIN / Vergleich aber kam immer ein Fehler.

https://www.herber.de/bbs/user/93087.xlsx

Vielen Dank im Voraus

  

Betrifft: dynamisch mit mit INDEX() und VERWEIS() ... von: neopa C (paneo)
Geschrieben am: 10.10.2014 11:58:40

Hallo,

.. in B5: folgende Formel und nach rechts kopieren:

=WENN(SPALTE(A1)>MIN(ANZAHL(Daten!$C:$C);12);"";INDEX(Daten!$C:$C;VERWEIS(9^9;Daten!$C:$C;ZEILE(A:A)) -MIN(ANZAHL(Daten!$C:$C);12)+SPALTE(A1))) 

Gruß Werner
.. , - ...


  

Betrifft: AW:oder mit 'Als Tabelle formatieren' arbeiten von: Luschi
Geschrieben am: 10.10.2014 12:41:51

Hallo D.Henschel,

hier mal eine Version, die die neuen Möglichkeiten der Formatvorlage 'Als Tabelle formatieren' nutzt.
Hinweise stehen in der Datei.

https://www.herber.de/bbs/user/93092.xlsx

Gruß von Luschi
aus klein-Paris


 

Beiträge aus den Excel-Beispielen zum Thema "Dynamischer Tabellenbereich - letzten 12 monate"