Microsoft Excel

Herbers Excel/VBA-Archiv

WENNFEHLER Problem

Betrifft: WENNFEHLER Problem von: Ralf
Geschrieben am: 14.10.2014 18:32:21

Hallo zusammen,

ich habe schon wieder mal ein Problem mit einer Formel.
=WENNFEHLER(WENN(E13kleinerD13;E13-D13;WENN(E13größerD13;E13-D13));"")
Sind die Zellen E13 oder D13 leer oder nur eine Zelle mit Wert gefüllt,
bekomme ich statt einer leeren Zelle entweder den einen Wert oder FALSCH.
Wie kann ich diesen Fehler beheben?
Kann mir da jemand auf die Sprünge helfen?

  

Betrifft: AW: WENNFEHLER Problem von: Hajo_Zi
Geschrieben am: 14.10.2014 18:35:23

E13größerD13;E13-D13;""
GrußformelHomepage


  

Betrifft: =WENN(ODER(E13="";D13="");"";E13-D13) von: WF
Geschrieben am: 14.10.2014 18:41:36

.


  

Betrifft: ohne WENNFEHLER ... von: Matthias L
Geschrieben am: 14.10.2014 18:53:00

Hallo

=WENN(ANZAHL(D13:E13)=2;MIN(D13:E13)-MAX(D13:E13);"")
Gruß Matthias


  

Betrifft: AW: ohne WENNFEHLER ... von: Ralf
Geschrieben am: 14.10.2014 19:00:25

Die ersten beiden Antworten ergeben FALSCH
und Matthias Lösung ergibt einen Negativwert obwohl der Wert positiv sein sollte,
behebt aber wohl die Fehlermeldungen.


  

Betrifft: dann rechne Max() - Min() von: Matthias L
Geschrieben am: 14.10.2014 19:04:00

Hallo

So wolltest Du es aber!
Du wolltest den größeren Wert vom kleineren Wert abziehen.
Lies Deine Frage nochmal.

Gruß Matthias


  

Betrifft: AW: dann rechne Max() - Min() von: Ralf
Geschrieben am: 14.10.2014 19:13:23

Sorry,
vielleicht habe ich es ja falsch beschrieben.
Ich möchte definitiv den Wert in E13 vom Wert in D13 abziehen.
E13 kann größer und auch kleiner als D13 sein.


  

Betrifft: AW: dann rechne Max() - Min() von: Hajo_Zi
Geschrieben am: 14.10.2014 19:42:32

warum dann so komplizierte Formel?
=E13-D13

Gruß Hajo


  

Betrifft: AW: dann rechne Max() - Min() von: Ralf
Geschrieben am: 14.10.2014 20:11:57

Hallo Hajo_Zi,

muss Dir recht geben.
Einfach ist manchmal besser!
Danke!
Dank auch an alle anderen für die Mühe!
LG
Ralf


 

Beiträge aus den Excel-Beispielen zum Thema "WENNFEHLER Problem"