Microsoft Excel

Herbers Excel/VBA-Archiv

Summenfunktion

Betrifft: Summenfunktion von: Scheff
Geschrieben am: 14.10.2014 19:16:31

Guten Abend,

ich bin auf der Suche nach einem Tool, mit welchem ich bei gegebener Summe die jeweiligen Summanden aus einer Zahlenmenge herausfinden kann.

Beispiel: Mein Zielwert ist 25.

Ich habe 7 Zahlen:
4
6
-8
22
125
19
7

Excel soll prinzipiell alle möglichen Summen (Anzahl Summanden ist egal) bilden und den bzw. die richtigen Summen-Terme zeigen.

Klar, dass es schnell extrem viele Möglichkeiten gibt. Daher als Zusatzfrage: Bis wieviele Einzelzahlen kann Excel die Vorgabe berechnen? Stochastiker ran!

Beste Grüße und Dank,

Scheff

  

Betrifft: AW: Summenfunktion von: Daniel
Geschrieben am: 14.10.2014 20:18:53

Hi
so ein tool musst du dir wahrscheinlich selber basteln.
ist aber nicht so schwer und die Datenmenge von 7 (eigentlich nur 6, denn mit den 125 kannst du den Zielwert nie erreichen) ist auch überschaubar.

hier ist noch die einfache BruteForce-Methode anwendbar:

1. Schreibe in die Zellen A1-G1 die Summanden
2. Schreibe in die Zellen A2-G2 die 0
3. Schreibe in die Zelle A3 die Formel: =NICHT(A2)*1
4. Schreibe in die Zelle B3 die Formel: =WENN(UND(NICHT(A3);A2);NICHT(B2);B2)*1
5. Ziehe die Formel aus B3 bis G3
6. Schreibe in die Zelle H3 die Formel: =Summenprodukt($A$1:$G$1;A3:G3)
7. Ziehe die Formeln aus A3-H3 soweit nach unten wie benötigt (bei 7 Elementen 2^7=128 Zeilen)

in Spalte H stehen jetzt die Summen aller möglichen Kombinationen und in den Spalten davor kannst du in Verbindung mit Zeile 1 ablesen, aus welchen Werten sie gebildet wurde (dort wo die 1 steht wurde der Wert genommen)
wenn du jetzt in Spalte H nach 25 filterst, kannst du alle Kombiantionen, die 25 ergeben ablesen.


bis vieliele Summanden das funkitioniert, kann ich dir nicht sagen.
das hängt wahrscheinlich vom Speicherplatz von Excel ab und von deiner Geduld.
Excel hat 2^20 Zeilen, dh bis 20 Elemente kannst so direkt verarbeiten. Bei mehr Elementen müsstest du dann eine zweite Reihe aufmachen, das ist bei der von mir vorgeschlagenen Bildungsmehtode der Kombinantion kein Problem.

Gruß Daniel


  

Betrifft: ich ziehe meinen Hut, Daniel. Respekt ! owT von: Matthias L
Geschrieben am: 15.10.2014 08:25:28




  

Betrifft: Zusatzfrage: Ab Xl12 255, das steht in der ... von: Luc:-?
Geschrieben am: 14.10.2014 20:21:21

…Hilfe zu SUMME, Scheffl;
ansonsten könnte der Solver eine Lösungsmöglichkeit sein. Aber willst du wirklich alle Summations­möglichkeiten haben? Das kann man sehr grob mit Kombinationen (ohne Wiederholung?) abschätzen und muss diese dann alle konstruieren (sofern die Komponenten < als die Summe sind, was durch negative Werte teilweise unwirksam wird) und auf ihr Summations­ergebnis prüfen, könnte ich mir als Lösungsweg vorstellen, was sicher mit VBA einfacher zu bewerkstelligen wäre; allerdings nur auch dann schneller, wenn's nicht endlos viele Möglichkeiten wdn.
Aber viell ist das ja gar nicht dein HptProblem, sondern nur dein bisheriger Lösungsansatz…?!
Gruß, Luc :-?