Microsoft Excel

Herbers Excel/VBA-Archiv

Variable Summewenns Formel bei der Spalte

Betrifft: Variable Summewenns Formel bei der Spalte von: Lutz
Geschrieben am: 15.10.2014 14:05:10

Hallo Excel-Profis,

ich habe mal wieder ein Problem bei dem ich ohne Hilfe keine Lösung finde.
Ich habe eine Summewenns – Formel bei der ich die Spalte für die zu summierenden Werte variabel halten muss.
=SUMMEWENNS(T1!BX14:BX1299;T1!$I$14:$I$1299;"x";T1!$H$14:$H$1299;”y”)

D.h. nur beim ersten Teil der Funktion: T1!BX14:BX1299 benötige ich die Möglichkeit das variabel zu halten.

Für Spalte BX wäre das z.B. 76 (76te Spalte) – den Wert 76 müßte ich also anstelle von BX in dem Part der Formel haben. Wenn ich dann auf 77 gehe dann müßte die Formel auf Spalte BY gehen.
P.S. die Formel muss von Zeile 14 bis 1299 gehen – die ganze Spalte nehmen geht leider nicht weil darüber und darunter andere Daten stehen.
Weiß jemand eine Lösung?

Vielen Dank für Eure Hilfe

Viele Grüße
Lutz

  

Betrifft: AW: Variable Summewenns Formel bei der Spalte von: Lutz
Geschrieben am: 15.10.2014 14:28:15

Schon erledigt:

SUMMEWENNS(BEREICH.VERSCHIEBEN(T1!$A$15:$A$1300;0;L$1).....

Viele Grüße Lutz


 

Beiträge aus den Excel-Beispielen zum Thema "Variable Summewenns Formel bei der Spalte"