Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN oder SUMMENPRODUKT oder?

Betrifft: SUMMEWENN oder SUMMENPRODUKT oder? von: Kathi
Geschrieben am: 16.10.2014 22:00:28

Hallo,

jetzt versuche ich es noch einmal mit Dateiupload:
https://www.herber.de/bbs/user/93202.xlsx

Ich möchte die Formeln für die blau markierten Zellen so bauen:
unter kumuliert 2014/2013 werden Daten aus der Registerkarte
"Daten" gezogen. Dabei orientiert sich die Formel aber aus der Vorgabe der Registerkarte "Auswertung" in den Zellen B1 und C1.

Unter kumuliert 2014 wird die Summe der jeweiligen Zeile von Januar bis zum unter C1 eingetragenen Monat des laufenden Jahres gezogen, unter kumuliert 2013 wird die Summe der jeweiligen Zeile von Januar des Vorjahres bis zum unter C1 eingetragenen Monat des Vorjahres gezogen.

Unter "alte Jahre gesamt" sollen die gesamten Jahressummen der jeweiligen Zeile des Vorjahres und des Vorvorjahres gebildet werden, hier ist C1 also nicht relevant - es sollen alle Spalten des jeweiligen Jahres aus dem Tabellenkopf aus der Registerkarte "Daten" addiert werden.

Ich hab schon viel versucht mit Wenn - dann, SVERWEIS etc. aber ich bekomme es nicht hin, dass die Summen flexibel, abhängig von B1 und C1 gezogen werden (da die Summen nur aus "Daten" gezogen werden können, weil in der "Auswertung" nicht immer alle benötigten Monate beinhaltet). Da immer nach einem abgelaufenen Monat in der Registerkarte "Daten" in Spalte B die neuen Daten hinzugefügt werden, muss ich die Tabelle so bauen.

Danke Euch!
Kathi

  

Betrifft: AW: SUMMEWENN oder SUMMENPRODUKT oder? von: Ewald
Geschrieben am: 17.10.2014 00:39:11

Hallo Kathi,

baue deine Datentabelle anders auf, wie im oberen Teil dargestellt,dann kannst du neue Monate einfach unten anfügen.

Die Auswertung kannst du dann wie im unteren Teil dargestellt vornehmen.(mußt natürlich anpassen)

 ABCDEF
1DatumJahrMonatBirnenÄpfelKirschen
230.09.201420149789
331.10.201420141091215
4      
5      
6      
7   201410Kirschen
8      
9    15 

NameBezug
Äpfel=Tabelle4!$E$2:$E$3
Birnen=Tabelle4!$D$2:$D$3
Kirschen=Tabelle4!$F$2:$F$3

ZelleFormel
B2=JAHR(A2)
C2=MONAT(A2)
B3=JAHR(A3)
C3=MONAT(A3)
E9=SUMMEWENNS(INDIREKT(F7);B2:B3;D7;C2:C3;E7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Ewald


  

Betrifft: SUMMENPRODUKT() ist schon anwendbar, obwohl ... von: neopa C (paneo)
Geschrieben am: 17.10.2014 07:57:05

Hallo Kathi,

... ich Ewald zustimme, dass Du mit einer anderen Tabellenstruktur einfacher hättest auswerten können. Allerdings hätte ich die Tabelle noch etwas anders aufgebaut und für die Auswertung auch kein INDIREKT() eingesetzt.

Für Deine Tabellenstruktur:

In N6:

=SUMMENPRODUKT((LINKS($B$2:$M$2;4)+0=N$2)*(0+RECHTS($B$2:$M$2;2)<=$C$1+0);$B6:$M6)  
und diese Formel nach unten und eine nach rechts kopieren.

In P6:
=SUMMENPRODUKT((LINKS($B$2:$M$2;4)+0=P$2)*$B6:$M6)

Gruß Werner
.. , - ...


  

Betrifft: AW: SUMMENPRODUKT() ist schon anwendbar, obwohl ... von: Ewald
Geschrieben am: 17.10.2014 10:25:27

Hallo Werner,

Indirekt ist ja nur als Beispiel wenn der Bereichsnamen aus einer Zelle kommen soll, du kannst ja auch einfach den Bereichsnamen direkt in die Formel eintragen, dann hat sich Indirekt erledigt.

Welche Formel zur Auswertung benutzt wird, ist ja dann egal, wenn die Tabelle Daten anders aufgebaut witd.

Gruß Ewald


 

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN oder SUMMENPRODUKT oder?"