Microsoft Excel

Herbers Excel/VBA-Archiv

Identifizierung anhand von bestimmten Werten

Betrifft: Identifizierung anhand von bestimmten Werten von: Sebastian
Geschrieben am: 23.10.2014 17:13:02

Hallo,

ich habe eine Auflistung von Patentansprüchen über 20 Spalten extrahiert (siehe mein vorheriges Problem: https://www.herber.de/forum/archiv/1384to1388/t1386408.htm). Die Ansprüche eines Patentes (1 Zeile = 1 Patent) werden also getrennt (1 Anspruch = 1 Zelle) aufgelistet. Da nicht jedes Patent 20 oder mehr Ansprüche enthält, werden in den jeweiligen Spalten der Wert 0 ausgewiesen. Hat ein Patent also bspw. nur 5 Ansprüche, enthalten die ersten 5 Zellen jeweils den Anspruch und die letzten 15 Zellen den Wert 0.

Ich möchte nun mit einer Formel jeweils feststellen ob es sich um einen abhängigen oder unabhängigen Anspruch handelt. Abhängige Ansprüche sind leicht dadurch zu identifizieren, dass sie das Wort „Claim“ enthalten (durch einen Rückbezug zu einem unabh. Anspruch).

Nun habe ich mir folgende Formel überlegt (Bsp. Für den 1. Anspruch):

=WENN(FINDEN("CLAIM";A1)=0;"Unabh";"Abh")

Hierdurch werden mir zwar alle abhängigen Ansprüche angezeigt, jedoch findet keine Unterscheidung zwischen den Zellen mit Wert 0 und den unabhängigen Ansprüchen statt.

Hat jemand eine bessere Lösung?

Ich hoffe die Logik meines Problems wird klar. Ansonsten fragt bitte einfach nochmal nach ;)

Vielen Dank im Voraus!

Sebastian

  

Betrifft: AW: Identifizierung anhand von bestimmten Werten von: Sebastian
Geschrieben am: 23.10.2014 18:15:03

Ich habe nochmal ein Sample hochgeladen und hoffe das macht mein Anliegen etwas verständlicher.

UC=Unabh
AC=Abh

https://www.herber.de/bbs/user/93323.xlsx

VG
Sebastian


  

Betrifft: AW: Identifizierung anhand von bestimmten Werten von: Werner
Geschrieben am: 23.10.2014 19:01:23

Hallo Sebastian,

so?

=WENN(C3=0;"";WENN(FINDEN("CLAIM";C3)=0;"UC";"AC"))

Werner


  

Betrifft: AW: Identifizierung anhand von bestimmten Werten von: Sebastian
Geschrieben am: 24.10.2014 14:13:34

Hallo Werner,

herzlichen Dank für den Vorschlag! In Kombination mit der WENNFEHLER Fkt klappt dann alles!

VG
Sebastian


  

Betrifft: AW: Danke für die Rückmeldung. owT von: Werner
Geschrieben am: 24.10.2014 17:55:28




 

Beiträge aus den Excel-Beispielen zum Thema "Identifizierung anhand von bestimmten Werten"