Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen wenn

Betrifft: Zählen wenn von: Werner
Geschrieben am: 24.10.2014 08:28:16

Hallo Excel-Freunde
habe ein Formular in welcher Berechnungen durgeführt werden sollen:
Berechnungen sollen in diesen Fall als Ergebnis in Zelle C13 stehen.
Folgendes soll berechnet werden:

Wenn in Zelle A13 das Word Ende steht, dann soll in Spalte A nach den letzten Eintrag Ende gesucht werden, dann aus der Spalte C eine Summe errechnet werden.

Beispiel:
Zelle A13 steht Ende
letztmalig steht in Zelle A8 Ende
Berechnung: Summe C9 - C12
zu beachten ist, das Ende öfters in Spalte A stehen kann.

Im voraus
vielen Dank
Werner

  

Betrifft: AW: Zählen wenn von: Werner
Geschrieben am: 24.10.2014 08:30:12

Habe die Datei hochgeladen:

https://www.herber.de/bbs/user/93330.xlsx


  

Betrifft: z.B. mit INDEX() ... von: neopa C (paneo)
Geschrieben am: 24.10.2014 08:43:59

Hallo Namensvetter,

... so: =WENN(A13="Ende";SUMME(INDEX(C$1:C12;VERWEIS(9;1/(A$1:A12="Ende");C$1:C12)):C12);[Deine weiter Formel])


Gruß Werner
.. , - ...


  

Betrifft: AW: z.B. mit INDEX() ... von: Werner
Geschrieben am: 24.10.2014 09:03:36

Hallo Werner

Vielen Dank für die rasche Antwort.
Zu deine weiter Formel habe ich folgendes Problem:
wenn in Spalte A13 nicht Ende steht dann soll in C13 die summe aus B13 - B12 errechnet werden.
Wenn in A13 jedoch Ende steht dann suche in Spalte A noch den vorletzten Eintrag mit Ende und berechne die Summe der Spalte C (letzter Eintrag Ende in Spalte A - vorletzter Eintrag Ende in Spalte A)
Gruß
Werner


  

Betrifft: AW: z.B. mit INDEX() ... von: Werner
Geschrieben am: 24.10.2014 11:47:16

Hallo
habe aus versehen das Problem als gelöst eingestellt.
Habe aber noch keine Lösung

Gruß
Werner


  

Betrifft: beginnend ab "Start"... von: neopa C (paneo)
Geschrieben am: 24.10.2014 16:33:40

Hallo Namensvetter,

... also bei Dir in C5 folgende Formel nach unten kopieren:

 ABC
5Start  
621.10.2014531,6 
723.10.2014531,60
8Ende531,60
9Start531,60
10 532,61
11 533,61
12 544,611
13Ende 13
14   

Formeln der Tabelle
ZelleFormel
C5=WENN((A5="Ende")*(ZÄHLENWENN(A$1:A4;"Ende")>0); SUMME(INDEX(C$1:C4;VERWEIS(9;1/(A$1:A4="Ende"); C$1:C4)):C4); WENN(ISTZAHL(B4); B5-B4;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen wenn"