Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit Bedingung Links

Betrifft: Summenprodukt mit Bedingung Links von: Hugo
Geschrieben am: 29.10.2014 08:15:04

Hallo

Habe ein Problem mit Summenprodukt mit Bedingung Links()

In Feld I6 wäre zum Beispiel der Wert 3.1
und ich suche nun alle Ausgaben!$D$6:$D$20000 = 3.1

Diese Formel gibt das korrekt Resultat:

=SUMMENPRODUKT(((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*((Ausgaben!$D$6:$D$20000)=I6) *Ausgaben!$H$6:$H$20000))

Nun steht aber in I6 nur der Wert 3
und ich suche nun alle in Ausgaben!$D$6:$D$20000 die links eine 3 haben
also 3.1 / 3.2 etc.

Habe schon alle möglichen Varianten wo ich links hinschreiben muss versucht
leider ohne Erfolg

=SUMMENPRODUKT((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*((LINKS(Ausgaben!$D$6:$D$20000;1)=I6))) *(Ausgaben!$H$6:$H$20000)

Was mache ich falsch?

Hoffe ich konnte mich Verständlich Ausdrucken und Ihr könnt mir rasch helfen

Besten Dank und Gruss

Hugo

  

Betrifft: AW: Summenprodukt mit Bedingung Links von: Hajo_Zi
Geschrieben am: 29.10.2014 08:21:50

Hallo Hugo,

es fehlt *1 Du vergleichst Text mit einer Zahl, würde ich vermuten.

GrußformelHomepage


  

Betrifft: inkorrekte Klammersetzung ... von: neopa C (paneo)
Geschrieben am: 29.10.2014 08:38:35

Hallo Hugo,

... ungetestet so: =SUMMENPRODUKT((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(LINKS(Ausgaben!$D$6:$D$20000;1)=I6)*(Ausgaben!$H$6:$H$20000))


Gruß Werner
.. , - ...


  

Betrifft: Nachtrag ... von: neopa C (paneo)
Geschrieben am: 29.10.2014 09:27:54

Hallo Hugo,

.... ich hatte allerdings vorhin wirklich vergessen aus dem Textwerten noch eine Zahl zu erstellen. :-( Sorry. Dies sollte mit der von Hajo bereits beschriebenen Multiplikation mit 1 (möglich wäre auch +0) geschehen.

Wollte also schreiben: =SUMMENPRODUKT((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(1*LINKS(Ausgaben!$D$6:$D$20000;1)=I6)*(Ausgaben!$H$6:$H$20000))

Allerdings ist die nun Deine Formelvariante:
=SUMMENPRODUKT(((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(LINKS(Ausgaben!$D$6:$D$20000)=TEXT(I6;0))) *(Ausgaben!$H$6:$H$20000)) die "sicherste" Variante, weil damit auch I6 mit einem vielleicht ungewollten Apostroph vor der Eingabe einer Zahl richtig berücksichtigt wird. :-)


Gruß Werner
.. , - ...


  

Betrifft: Wildcards in Summenprodukt von: Beate Schmitz
Geschrieben am: 29.10.2014 08:53:44

Hallo Hugo,

=SUMMENPRODUKT((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(ISTZAHL(FINDEN("3.";Ausgaben!$D$6:$D$20000))) *(Ausgaben!$H$6:$H$20000))

bzw.:
=SUMMENPRODUKT((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(ISTZAHL(FINDEN(LINKS(I6;2); Ausgaben!$D$6:$D$20000)))*(Ausgaben!$H$6:$H$20000))

Grüße,
Beate


  

Betrifft: AW: Summenprodukt mit Bedingung Links von: Hugo
Geschrieben am: 29.10.2014 08:53:55

Hallo

Besten Dank für die rasche Hilfe

Habe Hajos Tipp berücksichtig und die Formel angepasst und nun klappt's

=SUMMENPRODUKT(((JAHR(Ausgaben!$B$6:$B$20000)=$B$2)*(LINKS(Ausgaben!$D$6:$D$20000)=TEXT(I6;0))) *(Ausgaben!$H$6:$H$20000))

Das mit den Klammern: Es gehen beide Arten aber Text(I6,0) muss sein

Nochmals Besten Dank und Gruss

Hugo


 

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt mit Bedingung Links"