Microsoft Excel

Herbers Excel/VBA-Archiv

Gleiche Werte zusammenfassen und addieren

Betrifft: Gleiche Werte zusammenfassen und addieren von: Tom
Geschrieben am: 30.10.2014 09:10:25

Hallöchen,

habe eine sehr lange Tabelle mit Artikeldaten, die so aussieht:
Die Artikelnummer steht in der ersten Spalte und soll im Ergebnis nur noch einmal auftauchen. Alle Werte dahinter müssen addiert werden.

1 - 2 - 3 - 4
2 - 3 - 4 - 5
3 - 4 - 5 - 6
1 - 2 - 3 - 4
6 - 7 - 8 - 9
2 - 3 - 4 - 5
1 - 2 - 3 - 4

Ergebnis soll sein:

1 - 6 - 9 - 12
2 - 6 - 8 - 10
3 - 4 - 5 - 6
6 - 7 - 8 - 9

bekomme das einfach nicht hin, kann jemand helfen?

Vielen Dank in Voraus!

Tom

  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Hajo_Zi
Geschrieben am: 30.10.2014 09:20:31

Hallo Tom,


Tabelle2

 ABCDEFGHI
11234 16912
22345 26810
33456 3456
41234 6789
56789     
62345     
71234     
8         

verwendete Formeln
Zelle Formel Bereich N/A
F1=MIN(A:A)  
G1:I4=SUMMEWENN($A$1:$A$7;$F1;B$1:B$7)  
F2:F8{=WENN(MIN(WENN($A$1:$A$7>F1;$A$1:$A$7))=0;"";MIN(WENN($A$1:$A$7>F1;$A$1:$A$7)))}$F$2 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.17 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Tom
Geschrieben am: 30.10.2014 09:26:34

Hallo Hajo,
das nenn ich schnell. Ich hab wohl vergessen zu erwähnen, dass ich eine VBA Lösung suche. SORRY!
Die Tabelle mit den mehrmals vorkommenden Artikelnummern ist schon das Ergebnis eines Macros (Extrakt aus einer riesigen Tabelle. Im letzten Schritt sollen eben die doppelten Artikelnummen verschwinden und alle anderen Werte dahinter addiert werden.

Gruß TOM


  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Beverly
Geschrieben am: 30.10.2014 10:32:59

Hi Tom,

Sub Summieren()
    Dim objDictionary As Object
    Dim varBereich As Variant
    Dim lngZaehler As Long
    Dim arrDaten()
    Dim arrSumme()
    Set objDictionary = CreateObject("Scripting.Dictionary")
    varBereich = Range("A1:A7")
    For lngZaehler = LBound(varBereich) To UBound(varBereich)
        objDictionary(varBereich(lngZaehler, 1)) = 0
    Next
    arrDaten() = objDictionary.keys
    ReDim arrSumme(0 To UBound(arrDaten()), 0 To 3)
    For lngZaehler = 0 To UBound(arrDaten())
        arrSumme(lngZaehler, 0) = arrDaten(lngZaehler)
        arrSumme(lngZaehler, 1) = Application.SumIf(Range("A1:A7"), arrDaten(lngZaehler), Range( _
"B1:B7"))
        arrSumme(lngZaehler, 2) = Application.SumIf(Range("A1:A7"), arrDaten(lngZaehler), Range( _
"C1:C7"))
        arrSumme(lngZaehler, 3) = Application.SumIf(Range("A1:A7"), arrDaten(lngZaehler), Range( _
"D1:D7"))
    Next lngZaehler
    Range("F1").Resize(lngZaehler, 4) = arrSumme()
End Sub

GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Tom
Geschrieben am: 30.10.2014 10:49:44

... danke! Den Code kann ich gar nicht nachvollziehen, geht das nicht einfacher? ich probiers mal!

Tom


  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Beverly
Geschrieben am: 30.10.2014 11:11:52

Hi Tom,

klar, gibt auch einfacheren Code - z.B. diesen:

Sub Summieren2()
    Dim lngZaehler As Long
    Dim lngZeile As Long
    lngZaehler = 1
    For lngZeile = 1 To 7
        If Application.CountIf(Range("F1:F7"), Cells(lngZeile, 1)) = 0 Then
            Cells(lngZaehler, 6) = Cells(lngZeile, 1)
            Cells(lngZaehler, 7) = Application.SumIf(Range("A1:A7"), Cells(lngZeile, 1), Range(" _
B1:B7"))
            Cells(lngZaehler, 8) = Application.SumIf(Range("A1:A7"), Cells(lngZeile, 1), Range(" _
C1:C7"))
            Cells(lngZaehler, 9) = Application.SumIf(Range("A1:A7"), Cells(lngZeile, 1), Range(" _
D1:D7"))
            lngZaehler = lngZaehler + 1
        End If
    Next lngZeile
End Sub
Könnte aber länger dauern, wenn es sehr viele Daten sind.


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Gleiche Werte zusammenfassen und addieren von: Tom
Geschrieben am: 30.10.2014 12:02:15

danke, das wars, den versteh ich schon eher!

Viiiiiiiiiiiiiiiielen Dank!!!


 

Beiträge aus den Excel-Beispielen zum Thema "Gleiche Werte zusammenfassen und addieren"