Microsoft Excel

Herbers Excel/VBA-Archiv

wenn Folrmel

Betrifft: wenn Folrmel von: Yilmaz Mutluöztürk
Geschrieben am: 31.10.2014 09:33:00

Hallo Excel Freunde,

ich brauche mal klein bisschen Hilfe betreffend einer "Zählenwenn" Formel.

So sieht meine Tabelle aus

A B C D ... L
(Länder) (Datum)
DE 01.01.2013
UK 02.02.2013
PL 05.06.2014
DE 03.01.2013
DE 06.01.2014

So jetzt ist meine Frage, in Spalte A sind die Ländernamen(verkürztes Version) und in Spalten B und L befinden sich Datums.
Die Spalte B gibt Info. über "X" Aktionen und die Spalte L "Y" Aktionen. Jetzt wenn ich die gesamte X-Aktionen für Deutschland(DE) berechnen muss, wie soll ich vorgehen. Ich habe mit folgenden Formel probiert, aber es gibt sich immer ein Fehler.

Die gesamte X-Aktionen, die in Deutschland durchgeführt wurden, habe ich die folgende Formel verwendet. Es sind zwei Bedienungen, in Spalte A muss das Wort "DE" vorkommen und in Spalte B muss ein Datum sein.

"Zählenwenns(Daten!$A$2:$A$202;"DE";Daten!$B$2:$B$202;"1")"

könnte jemand mir halfen, was fehlt bei der Formel?

MFG
Yilmaz

  

Betrifft: AW: wenn Folrmel von: SF
Geschrieben am: 31.10.2014 09:50:00

Hola,

meinst du das so?

=Zählenwenns(Daten!$A$2:$A$202;"DE";Daten!$B$2:$B$202;">0")
Gruß,
steve1da


  

Betrifft: AW: wenn Folrmel von: Yilmaz Mutluöztürk
Geschrieben am: 31.10.2014 11:46:38

Danke Steve1da, es hat funktioniert mit deinem Vorschlag

Gruss
Yilmaz


  

Betrifft: AW: wenn Folrmel von: yummi
Geschrieben am: 31.10.2014 09:55:09

Hallo Yilmaz,

so zählst Du alle DE die in Spalte B nicht leer sind

=ZÄHLENWENNS(A:A;"DE";B:B;"<>"&"")

Gruß
yummi


  

Betrifft: &"" brauchst du nicht von: Rudi Maintaire
Geschrieben am: 31.10.2014 11:01:07

Hallo,
=ZÄHLENWENNS(A:A;"DE";B:B;"<>")
reicht.

Gruß
Rudi