Microsoft Excel

Herbers Excel/VBA-Archiv

Datum zuordnen

Betrifft: Datum zuordnen von: DirkR
Geschrieben am: 31.10.2014 11:27:13

Hallo Excelgemeinde,

ich stehe gerad völlig auf dem Schlauch und brauche Hilfe.

Ich möchte gerne bei Mitarbeitern ein Datum in der nächsten Spalte eintragen. Dieses Datum soll gefiltert an anderer Stelle jeweils in den Spalten (Jahre) und in den Zeilen (Namen) erscheinen.

In der Beispielmappe habe ich das mal dargestellt.

Hier eine Beispielarbeitsmappe:
https://www.herber.de/bbs/user/93472.xlsx

Hoffe auf Hilfe

Gruß DirkR

  

Betrifft: AW: Datum zuordnen von: DirkR
Geschrieben am: 31.10.2014 11:31:37

Hatte leider einen Fehler in der Beispielmappe! :-(

hier die korrigierte Datei:
https://www.herber.de/bbs/user/93473.xlsx

Gruß DirkR


  

Betrifft: AW: Datum zuordnen von: SF
Geschrieben am: 31.10.2014 11:37:47

Hola,

schreib in D3:

=jahr(C3)

und kopiere die Formel nach unten.

Schreibe die Namen in H3 bis H3 zusammen, so wie auch in B3 bis B6. In I3 dann:

=WENNFEHLER(VERWEIS(2;1/($B$3:$B$6&$D$3:$D$6=$H3&I$2);$C$3:$C$6);"")
Gruß,
steve1da


  

Betrifft: AW: Datum zuordnen von: SF
Geschrieben am: 31.10.2014 11:33:56

Hola,

warum die Namenstrennung beim Wunschergebnis? Warum tauchen Josef Klein zwei Daten auf, jedoch keines von beiden ist der 01.07.2014?

Gruß,
steve1da


  

Betrifft: AW: Datum zuordnen von: Rudi Maintaire
Geschrieben am: 31.10.2014 11:36:32

Hallo,
das Bsp ist falsch
Matrixformel in I3: {=WENN(MAX(($B$3:$B$6=$G3&" "&$H3)*(JAHR($C$3:$C$6)=I$2)*$C$3:$C$6)>0;MAX(($B$3:$B$6=$G3&" "&$H3)*(JAHR($C$3:$C$6)=I$2)*$C$3:$C$6);"")}

Gruß
Rudi


  

Betrifft: AW: Datum zuordnen von: DirkR
Geschrieben am: 01.11.2014 11:08:00

Hallo,
vielen danke für die Lösungsvorschläge. Beide Formellösungen funktionieren.

Ich habe nun noch den Wunsch die Anzahl der Daten in dem jeweiligen Jahr der Person zuzuordnen, falls bei einer Person 2 Daten vom selben Jahr eingegeben werden...

Hier die Beispielmappe:
https://www.herber.de/bbs/user/93485.xlsx

Danke schon mal...

Gruß DirkR


  

Betrifft: AW: Datum zuordnen von: DirR
Geschrieben am: 02.11.2014 11:54:53

Habe es hinbekommen!!! ;-)

daher Beitrag geschlossen.

Gruß DirkR


 

Beiträge aus den Excel-Beispielen zum Thema "Datum zuordnen"