Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema RefEdit
BildScreenshot zu RefEdit RefEdit-Seite mit Beispielarbeitsmappe aufrufen

Summe über undefinierten Bereich

Betrifft: Summe über undefinierten Bereich von: Ecker
Geschrieben am: 12.11.2014 10:43:31

Hallo, eine vielleicht etwas kompliziertere Frage aber vielleicht hat ja jemand eine einfache Lösung. Zum besseren Verständins habe ich hier gleich mal ein Beispielbild



Jeder "Posten" (ID) hat eine variable Anzahl an Zeilen. Jede Zeile hat einen Wert. Nun soll die Summe für eine Bestimmte ID gebildet werden.

In der Spale ID sollte diese Nur einmal stehen da in einem Formular mittels Dropdownmenü die ID´s ausgewählt werden und es unschön ist wenn jede ID 10 mal darin Auftaucht.

Die Formel sollte außerdem kopierbar sein, heißt einfaches Runterziehen über 5000 Zeilen

Ich habe schon verschiedene Sachen mit Indirekt, Summewenn usw... ausprobiert scheitere jedes mal aber an einer Kleinigkeit.

Schonmal vielen Dank
Grüße Benni

  

Betrifft: Doppelt von: Hajo_Zi
Geschrieben am: 12.11.2014 10:52:20

https://www.herber.de/forum/messages/1391821.html


  

Betrifft: mit INDEX() und VERWEIS() ... von: neopa C (paneo)
Geschrieben am: 12.11.2014 10:52:56

Hallo Benni,

... in F3:

=WENN((C4>0)+(C4=0)*(D4=0)*(E3<>0);SUMME(INDEX(E:E;VERWEIS(9^9;C$2:C2;ZEILE(C$2:C2))):E3);"") 
und Formel nach unten kopieren. Die Summe steht in der letzten Zelle des ID-Wertes.


Gruß Werner
.. , - ...


  

Betrifft: Korrektur ... und Hinweis ... von: neopa C (paneo)
Geschrieben am: 12.11.2014 16:21:18

Hallo Benni,

... meine Formel von heute Vormittag hat einen (ungewollten) Spaltenversatz in den Daten gegenüber Deinen Vorgaben angenommen. Sorry. Richtig sollte meine Formel dann wie untenstehend aufgezeigt lauten.

Allerdings hat Hansueli Dein Bild genauer angeschaut und Dir hier: https://www.herber.de/forum/messages/1391933.html eine einfachere Lösung aufgezeigt, als meine nachfolgende:

 BCDE
2IDLZWerteSumme
3120012 
4 23 
5 34 
6 45 
7 55 
8 63 
9 74 
10 86 
11 97 
12 103 
13 114 
14 126 
15 13456
16120214 
17 2711
18120413 
19 469
20    

Formeln der Tabelle
ZelleFormel
E3=WENN((B4>0)+(B4=0)*(C4=0)*(D3<>0); SUMME(INDEX(D:D;VERWEIS(9^9;B$2:B2;ZEILE(B$2:B2))):D3); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Summe über undefinierten Bereich"