Microsoft Excel

Herbers Excel/VBA-Archiv

Summeprodukt mit 2 Kriterien

Betrifft: Summeprodukt mit 2 Kriterien von: Dirk L.
Geschrieben am: 13.11.2014 11:31:03

Hallo Profis,

ich brauche mal wieder eure Hilfe. Ich habe eine Tabelle mit 8 Spalten. In der Spalte A stehen Datumsangaben (TT.MM.JJJ / Kriterium 1), in Spalte E steht das zweite Kriterium (variabel). In einer weiteren Tabelle soll dann eine Gesamtberechung gemacht werden.
Aufgabe kurz beschrieben, summiere ale Kosten für z.B. August 2014, die für Kriterium a angefallen sind.
Für die Gesamtsumme zu einem Monat habe ich bereits eine Formel {=SUMMENPRODUKT(((MONAT($A$2:$A$148)=8)*JAHR($A$2:$A$148)=2014)*($C$2:$C$148))}.

Habe euch eine Beispieldatei beigefügt.

https://www.herber.de/bbs/user/93742.xlsx

Danke im Voraus.

Gruß
Dirk

  

Betrifft: AW: Summeprodukt mit 2 Kriterien von: Hajo_Zi
Geschrieben am: 13.11.2014 11:34:42

Hallo Dirk,

keine Array Formel und Klammern beachten.
=SUMMENPRODUKT((MONAT($A$2:$A$148)=8)*(JAHR($A$2:$A$148)=2014)*($C$2:$C$148))

GrußformelHomepage


  

Betrifft: besser drei Bedingungen, um ... von: neopa C (paneo)
Geschrieben am: 13.11.2014 11:43:43

Hallo Dirk,

... vorsichtshalber (für spätere Auswertungen) auch das Jahr zu berücksichtigen.

In G2: =SUMMENPRODUKT((MONAT($A$2:$A$999)=MONAT($E2))*(JAHR($A$2:$A$999)=JAHR($E2))*($B$2:$B$999=G$1);$C$2:$C$999)
und Formel nach rechts und unten kopieren.


Gruß Werner
.. , - ...


  

Betrifft: AW: besser drei Bedingungen, um ... von: Dirk L.
Geschrieben am: 13.11.2014 15:27:01

Hallo Werner,

da sag ich doch mal Danke, klappt super

Gruß
Dirk


 

Beiträge aus den Excel-Beispielen zum Thema "Summeprodukt mit 2 Kriterien"