Microsoft Excel

Herbers Excel/VBA-Archiv

zählewenn verschachtelt

Betrifft: zählewenn verschachtelt von: Christian Gasser
Geschrieben am: 19.11.2014 20:11:57

Hallo
Mein Problem ist folgendes: In einem Dienstplan möchte ich herausfinden, wer wie viele und was für Touren an einem Samstag zu arbeiten hat, wer wie viele und was für Touren an einem Sonntag.
Zeile eins = Daten (einen Monat, jede Spalte ein Datum)
Zeile 2 = Wochentag (Datum von oben übernommen, programmiert benutzerdefiniert mit Mo, Di, ...)
Das ganze ist so verformelt, dass man jeden Monat die gleiche Datei benützen kann (Eingabe in Zelle a1: 01.01.15 = Monat Januar15, alle Daten passen sich an)
Ab Zeile 4 - x sind die Touren (Zahlen zwischen 112 - 139) eingegeben., die eine Person (Name in Spalte A) zu arbeiten hat.
Meine Idee war, ab Spalte AH ein Listung zu haben Tour 112 Sa, Tour 112 So, ...
Mit Zählewenn kann ich alle Touren 112 zusammenzählen. Wenn aber jetzt noch das Kriterium dazukommt, Zähle alle Touren 112 an einem Samstag, wie mache ich das am einfachsten?
Sorry, wollte eine Datei hochladen, aber obwohl im Laufwerk C abgespeichert und eine Exceldatei, kommt die Meldung, ... muss eine Endung auf xl* haben.
Merci für die Mühe.

  

Betrifft: vermutlich mit Summenprodukt ... von: Matthias L
Geschrieben am: 19.11.2014 20:49:02

Hallo

Probiers nochmal mit hochladen, das sollte eigentlich kein Problem sein

Im Namen der Datei keine Leerzeichen!
Die Größe darf 300 kb nicht überschreiten

Gruß Matthias


  

Betrifft: AW: vermutlich mit Summenprodukt ... von: Christian Gasser
Geschrieben am: 19.11.2014 20:57:47

Voilà, hatte einen Umlaut im Dateiennamen, ohne funktionierte es:

https://www.herber.de/bbs/user/93883.xlsx


  

Betrifft: AW: mit Summenprodukt von: hary
Geschrieben am: 20.11.2014 08:14:06

Moin
Zeile2 in der Auswerung braucht es nicht. Nur zur optischen Sicherheit.



Tabelle1

 AHAIAJAK
1112112113113
2sasosaso
3    
41000

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
AH4:AK4=SUMMENPRODUKT(($B4:$AF4=AH$1)*(WOCHENTAG($B$2:$AF$2;2)=6+REST(SPALTE();2)))  =SUMPRODUCT((RC2:RC32=R1C)*(WEEKDAY(R2C2:R2C32,2)=6+MOD(COLUMN(),2)))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: mit Summenprodukt von: Christian Gasser
Geschrieben am: 20.11.2014 20:14:49

Hallo,
funktioniert einwandfrei, besten Dank

Chrigu