Microsoft Excel

Herbers Excel/VBA-Archiv

FormulaLocal Problem!!

Betrifft: FormulaLocal Problem!! von: Les
Geschrieben am: 21.11.2014 01:52:28

Hallo forum :)

Hab in Zelle B23 ein wert, der sich je nach Artikel ändert!
Der Kode ganz unten sorgt für die Zellveränderung, sobald das wert der Zelle "koffer" ist. Bis dahin alles ok.

Nun wollte ich in eine von die geänderte Zellen ein Formel schreiben.
Es sollte so aussehen:

ThisWorkbook.Sheets("TB1").Range("O30").FormulaLocal = "=SVERWEIS((SVERWEIS(A28;A3: _
L22;2;FALSCH));'Mini Datenbank'!B:BP;64;0)"
Dies Formel funzt schon wo anders aber hier nicht!
Es fängt dann Minuten lang ein schreiben und löschen Aktion, als ob die untere Kode bis "else" sich in eine schleife befindet und in eine Sekunde 10 mal von vorne anfängt!

Hat jemand ein Idee wie ich die Formel problemlos in die Zelle schreiben lassen kann.

Danke

Option Explicit
Private Sub Worksheet_Change(ByVal Target As Range)

Dim kuku As String

kuku = ThisWorkbook.Sheets("TB1").Range("B23").Value

    If kuku <> "koffer" Then
    ThisWorkbook.Sheets("TB1").Range("M30:P30").MergeCells = False
    ThisWorkbook.Sheets("TB1").Range("M30:N30").MergeCells = True
    ThisWorkbook.Sheets("TB1").Range("M32:P32").MergeCells = False
    ThisWorkbook.Sheets("TB1").Range("M32:N32").MergeCells = True
    ThisWorkbook.Sheets("TB1").Range("O30:Q32").MergeCells = True
    ThisWorkbook.Sheets("TB1").Range("O30").Font.Size = 45
    ThisWorkbook.Sheets("TB1").Range("J28:Q68").Interior.ThemeColor = xlThemeColorDark1
    
    ThisWorkbook.Sheets("TB1").Range("O30").FormulaLocal = "=SVERWEIS((SVERWEIS(A28;A3: _
L22;2;FALSCH));'Mini Datenbank'!B:BP;64;0)"

        Else
        
        ThisWorkbook.Sheets("Etiketler").Range("O30:Q32").MergeCells = False
 
        End If
End Sub

  

Betrifft: AW: Event ausschalten von: hary
Geschrieben am: 21.11.2014 06:56:51

Moin
Bei jedem Eintrag wird der Code neu gestartet.
So

Application.EnableEvents = False
'dein Code
Application.EnableEvents = True

kannst du das ausschalten.
gruss hhary


  

Betrifft: AW: Event ausschalten von: Les
Geschrieben am: 21.11.2014 08:33:40

Danke hary,

hat geklappt :)