Microsoft Excel

Herbers Excel/VBA-Archiv

Pivot-Tabelle

Betrifft: Pivot-Tabelle von: Michael
Geschrieben am: 21.11.2014 11:40:33

Hallo, ich habe eine Frage bzgl. einer Pivottabelle!

Folgendes Problem, ich habe ein Excelsheet aus einer Datenbank.
In Diesem Excelsheet befinden sich jede Menge Artikel und deren Verwendungsnachweise, von diesen Verwendungsnachweisen habe ich noch den Artikelstatus (Auslauf, Gesperrt, Freigegeben, usw..)!

Daraus habe ich eine Pivottabelle gemacht in der ich jetzt übersichtlich alle Artikel mit den jeweiligen Verwendungen sehe und deren Status.

Mein Problem kommt nun:
Ich habe eine riesige Anzahl an Artikel und möchte NUR jene Nummern haben hinter denen NUR Artikel stehen welche gesperrt sind.

Kann mir jemand dabei helfen das Problem zu lösen?

ganz liebe Grüße!

  

Betrifft: AW: Pivot-Tabelle von: fcs
Geschrieben am: 21.11.2014 14:02:07

Hallo Michael,

was meinst du wozu die Dropdown-Auswahl bei den Feldnamen ist? Oder hast du die Feldkopfzeilen untern den Optionen abgeschaltet?
Hier kannst du Filter setzen, welche Werte in der Auswertung angezeigt werden sollen.

Wähle für das Feld "Artikelstatus" erst den Eintrag "(Alle anzeigen) ab und markieren dann den Eintrag "Gesperrt".

Gruß
Franz


  

Betrifft: AW: Pivot-Tabelle von: Michael
Geschrieben am: 24.11.2014 08:38:08

Hallo Franz!

Danke für deine Antwort. Wenn ich das so mache wie du es mir beschrieben hast, werden mir alle Artikel angezeigt in denen sich ein gesperrter Artikel befindet!
Ich möchte jedoch alle Artikel haben in denen NUR gesperrte Artikel sind.

lg Michael


  

Betrifft: AW: Pivot-Tabelle von: Michael
Geschrieben am: 24.11.2014 08:57:26

Hallo Franz!

Danke für deine Antwort. Wenn ich das so mache wie du es mir beschrieben hast, werden mir alle Artikel angezeigt in denen sich ein gesperrter Artikel befindet!
Ich möchte jedoch alle Artikel haben in denen NUR gesperrte Artikel sind.

lg Michael


  

Betrifft: AW: Pivot-Tabelle von: fcs
Geschrieben am: 24.11.2014 10:13:43

Hallo Michael,

diese Form der Auswertung kann der Pivotbericht nicht leisten.

Ausweg 1:
in den Quelldaten wird eine Hilfsspalte eingefügt, die alle Nr mit 0 kennzeichnet, die nur gesperrte Artikel enthält.
Formelbeispiel: =SUMMENPRODUKT(([Nr]=[@Nr])*([Status]<>"gesperrt")*1)

Dieses Hilfsfeld kann man in der Pivot einbauen und dann den Filter für das Feld auf 0 setzen.
Allerdings ist die Formel bei einer Tabelle mit vielen Datenzeilen sehr rechenintensiv.


Ausweg 2:
Du erstellst einen Pivotbericht mit Nummer als Zeilenfeld und Status als Spaltenfeld, "Anzahl Artikel" als Datenfeld. Als Berichtslayout "in Tabellenformat anzeigen" wählen.
Jetzt kopierst du die Ergebnisdaten des Pivotberichtes und fügst sie in ein leeres Tabellenblatt als Werte ein. Jetzt kannst du per Autofilter bei allen Statuswerten außer "gesperrt" durch setzen des Filters auf "(leere")" die Zeilen mit Werten aublenden.
Übrig bleiben dann in der Anzeige die Nummern, die nur gesperrte Artikel enthalten.

Gruß
Franz


  

Betrifft: AW: Pivot-Tabelle von: Michael
Geschrieben am: 24.11.2014 11:18:31

Hallo Franz.
Ich danke dir vielmals für deine Hilfe!

Ich werde das gleich ausprobieren.

lg Michael


  

Betrifft: AW: Pivot-Tabelle von: Michael
Geschrieben am: 24.11.2014 11:24:00

Hallo Franz, ich würde mich über noch eine kurze Hilfestellung freuen!

Bzgl. deiner Bspl. Formel "=SUMMENPRODUKT(([Nr]=[@Nr])*([Status]<>"gesperrt")*1)"

Ist höchstwahrscheinlich eine etwas doofe Frage, aber könntest du mir deine Variablen erklären? Habe mit "SUMMENPRODUKT" noch nie etwas zu tun gehabt.

lg


  

Betrifft: AW: Pivot-Tabelle von: fcs
Geschrieben am: 24.11.2014 11:37:35

Hallo Michael,

die Formel gilt, wenn die Daten als Tabellenobjekt vorliegen.

mit Standardzellbezügen sieht es etwa so aus:

Formel z.B. in F2:
=SUMMENPRODUKT(($A$2:$A$8890=A2)*($D$2:$D$8890<>"gesperrt")*1)

in Spalte A stehen die Nummern, in Spalte D die Status-Werte.

Gruß
Franz


  

Betrifft: AW: Pivot-Tabelle von: Michael
Geschrieben am: 24.11.2014 12:23:41

Perfekt, jetzt hab ich auch das noch verstanden!

Habe das Ganze jetzt ohne Formeln, nur über Pivot gelöst!
Funktioniert wunderbar - vielen Dank für die sehr kompetente und freundliche Hilfe!