Microsoft Excel

Herbers Excel/VBA-Archiv

Datenfelder farblich hervorheben

Betrifft: Datenfelder farblich hervorheben von: Jean Gitanes
Geschrieben am: 21.11.2014 12:28:32

Guten Tag,

in Spalte G stehen Straßennamen mit und ohne Hausnummern.
Wie kann man die Datenfelder farblich hervorheben, die keine Hausnummer besitzen?

Gruß
Jean

  

Betrifft: AW: Datenfelder farblich hervorheben von: Daniel
Geschrieben am: 21.11.2014 12:48:01

Hi
wenn man davon ausgeht, dass die Hausnummer rechts steht, dann kannst du mit der Formel prüfen:

=Istzahl(1*Rechts(G1;1))

Diese hat das Ergebnis WAHR wenn das letzte Zeichen im Text eine Ziffer ist.

du kannst die Formel dann in der Bedingten Formatierung verwenden um die Zellen zu färben oder in einer Hilfsspalte, um dann in dieser Hilfsspalte den Autofilter verwenden zu können.

bei Hausnummern mit Buchstabenzusatz (12a) kannst du ja das letzte und vorletze Zeichen prüfen:
=Oder(IstZahl(1*rechts(G1;1));IstZahl(1*links(Rechts(G1;2);1)))
eine weiter mögliche Formel wäre diese:
=SUMMENPRODUKT(ISTZAHL(FINDEN(""&ZEILE($A$1:$A$10)-1;G1))*1)

bei Strassennamen ohne Ziffer (Hausnummer) ist das Ergebnis 0, mit Hausnummer ein Wert >0 (anzahl der unterschiedlichen Ziffern), egal wo diese steht.

Gruß Daniel


  

Betrifft: Danke von: Jean Gitanes
Geschrieben am: 21.11.2014 13:01:01

Hallo Daniel,

Klasse, Deine Vorschläge.
Die helfen mir weiter. Danke

Gruß
Jean


 

Beiträge aus den Excel-Beispielen zum Thema "Datenfelder farblich hervorheben"