Microsoft Excel

Herbers Excel/VBA-Archiv

summe of zellen innerhalb eines arrays

Betrifft: summe of zellen innerhalb eines arrays von: Lutz
Geschrieben am: 21.11.2014 21:20:27

Hallo zusammen,

ich versuche seit meheren Tagen folgendes Excel Problem zu loesen:

Ich habe eine Spalte mit 8760 Zeilen gefuellt mit positiven/negativen Zahlen und Nullen. Die Zahlen (Zellen) die von Nullen getrennt warden stellen einen Block dar. Z.b.: Zelle A222=0, A223 - A300 = pos./neg. Zahlen. A301 = 0 danach kommen beliebig viele Nullen bevor wieder ein Block mit Zahlen ungleich Null folgt.

Was ich versuche ist, die Summe der jeweiligen Bloecke zu ermitteln und falls die Summe positiv ist, den Wert der einzelen Zelen zu uebernehmen. Angegnommen die Summe des Blocks im Beispiel is positiv, B223 - B300 wuerde die jeweiligen Zahlen von A223 - A300 uebernehmen.

Das einzige Kriterium: die Umsetzung sollte ohne Array Formel umgesetzt werden (ich habe eine array-variante die funktioniert aber mein model extreme verlangsamt) und auch nicht mittels Makro.

Ich bin fuer jeden Ansatz dankbar.

Gruss Lutz

  

Betrifft: Zeigst du mal die Variante, danke. owT von: Matze Matthias
Geschrieben am: 22.11.2014 09:11:53




  

Betrifft: eine Lösung ohne MATRIXFormel ... von: neopa C (paneo)
Geschrieben am: 22.11.2014 16:59:07

Hallo Lutz,

... in B2 folgende Formel und diese dann nach unten kopieren, sollte den gewünschten Effekt ergeben.
Die 999 in der Formel könnte evtl. noch verkleinert werden, wenn die Bereiche entsprechend kleiner sind. Du kannst es ja gleich mal mit 99 versuchen. Notfalls kann ich in einer Hilfszelle den max. Ausdehnungsbereich auch mit einer MATRIXformel ermitteln und es wird dieser Wert genutzt.

=WENN((A1=0)*(A2<>0)*(SUMME(A2:INDEX(A2:A999;VERGLEICH(0;A2:A999;0)))>0)+(A2<>0)*(B1<>"");A2;"") 
Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "summe of zellen innerhalb eines arrays"