Microsoft Excel

Herbers Excel/VBA-Archiv

Spalte bis zu einem bestimmten Wert sortieren

Betrifft: Spalte bis zu einem bestimmten Wert sortieren von: Lisa Geroldt
Geschrieben am: 23.11.2014 11:04:48

Guten Morgen!

Ich hänge leider gerade an einem kleinen Problem.

Spalte A:
Dienstag, 25. November 2014
10:00
10:00
10:00
15:45
15:45
Montag, 24. November 2014
08:00
14:30
14:30
Mittwoch, 26. November 2014
12:00
14:30
Montag, 24. November 2014
20:30
22:00
Dienstag, 25. November 2014
6:45

In Spalte B soll allen Uhrzeiten an einem Montag eine 1, am Dienstag eine 2 usw. zugeordnet werden.
Kann mir jemand einen Ansatzpunkt geben? Würde mich sehr freuen!

Lisa

  

Betrifft: AW: Spalte bis zu einem bestimmten Wert sortieren von: Gerd L
Geschrieben am: 23.11.2014 11:37:57

Hallo Lisa,

falls ab A2 abwärts keine Lücken dazwischen u. das Datum ist jeweils kein reiner Text.

Sub a()

Dim lf As Long, WT

For lf = 2 To Cells(2, 1).End(xlDown).Row
    With Cells(lf, 1)
        If .Value > 1 Then
            WT = Weekday(Cells(lf, 1).Text, vbMonday)
        Else
            .Offset(0, 1).Value = WT
        End If
    End With
Next

End Sub
Gruß Gerd


  

Betrifft: alternativ mit einer Formel ... von: neopa C (paneo)
Geschrieben am: 23.11.2014 11:43:55

Hallo Lisa,

... wobei ich davon ausgehe, dass Deine Datumsangaben Textwerte sind (ansonsten wird die Formel einfacher)

Folgende Formel in B1 und nach unten kopieren:

=WENN(A1="";"";REST(--TEIL(VERWEIS(9;1/ISTTEXT(A$1:A1);A$1:A1);FINDEN(",";VERWEIS(9;1/ISTTEXT(A$1:A1) ;A$1:A1))+2;99)-1;7))


Gruß Werner
.. , - ...


  

Betrifft: AW: alternativ mit einer Formel ... von: Lisa Geroldt
Geschrieben am: 23.11.2014 12:09:13

Ich danke vielmals!

Einen schönen Sonntag noch.

Lisa


  

Betrifft: AW: alternativ mit einer Formel ... von: Lisa Geroldt
Geschrieben am: 23.11.2014 13:37:35

Hallo Werner,

eine ergänzende Frage noch:

=WENN(A1="";"";REST(--TEIL(VERWEIS(9;1/ISTTEXT(A$1:A1);A$1:A1);FINDEN(",";VERWEIS(9;1/ISTTEXT(A$1:A1)  ;A$1:A1))+2;99)-1;7))  
Ist es auch möglich, um anstelle der Zahlen 1-7 direkt das jeweilige Datum ausgegeben zu bekommen?

Viele Grüße
Lisa


  

Betrifft: AW: alternativ mit einer Formel ... von: Lisa Geroldt
Geschrieben am: 23.11.2014 13:37:44

Hallo Werner,

eine ergänzende Frage noch:

=WENN(A1="";"";REST(--TEIL(VERWEIS(9;1/ISTTEXT(A$1:A1);A$1:A1);FINDEN(",";VERWEIS(9;1/ISTTEXT(A$1:A1)  ;A$1:A1))+2;99)-1;7))  
Ist es auch möglich, um anstelle der Zahlen 1-7 direkt das jeweilige Datum ausgegeben zu bekommen?

Viele Grüße
Lisa


  

Betrifft: dann verkürzt sich die Formel ... von: neopa C (paneo)
Geschrieben am: 23.11.2014 16:13:32

Hallo Lisa,

... in B1 so:

=WENN(A1="";"";--TEIL(VERWEIS(9;1/ISTTEXT(A$1:A1);A$1:A1);FINDEN(",";VERWEIS(9;1/ISTTEXT(A$1:A1); A$1:A1))+2;99)) 
und den Zellen das Datumsformat zuweisen.

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Spalte bis zu einem bestimmten Wert sortieren"