Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

SUMMEWENN Nach Textteil zusätzlich filtern

SUMMEWENN Nach Textteil zusätzlich filtern
23.03.2015 08:28:09
Juri
Hey Leute! Kurz knapp knackig - ich hab diese Funktion
=SUMMEWENN(G:G;D2115;C:C)
und in Zeile E steht ein Text in diesem Text befindet sich jetzt eine Buchstabenkombination als irgendein Zufallsbeispiel: w02 etg/xxxx/x oder anstatt etg ein etb oder ein set.
Ich möchte das so, dass die Funktion halt noch auf diese 3 Teile gefiltert wird, aber wenn ich da "*ETG*" in die Funktion einfüge, kommt ein Fehler... Hat da jemand eine Idee?
Danke schon Mal :)
LG Juri

26
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
nutze dazu SUMMEWENNS() ...owT
23.03.2015 09:07:08
neopa
Gruß Werner
.. , - ...

AW: nutze dazu SUMMEWENNS() ...owT
23.03.2015 09:29:38
Matthias
Hallo Juri
=SUMMEWENN(B:B;"*et*";A:A) sollte funktionieren
Gruß

AW: nutze dazu SUMMEWENNS() ...owT
23.03.2015 09:30:32
Juri
Tut es leider nicht, wie in meiner Beschreibung schon erwähnt.

AW: SUMMEWENN Nach Textteil zusätzlich filtern
23.03.2015 09:08:19
SF
Hola,
ungetestet:
=SUMMENPRODUKT((G2:G10=D2115)*((ISTZAHL(FINDEN("etb";E2:E10))+(ISTZAHL(FINDEN("etg";E2:E10)) +(ISTZAHL(FINDEN("set";E2:E10)))*(C2:C10))))) Gruß,
steve1da

AW: SUMMEWENN Nach Textteil zusätzlich filtern
23.03.2015 09:16:32
Juri
Hey - Funktioniert leider nicht, bzw. kommt "0" raus... Außerdem brauche ich erst mal nur ETG, ETB oder SET und nicht alle 3 auf einmal.. Die restlichen kann ich in einer anderen Zeile filtern... War blöd formuliert von mir...

Anzeige
AW: SUMMEWENN Nach Textteil zusätzlich filtern
23.03.2015 09:17:54
SF
Hola,
die Formel sucht nach ETG oder ETB oder SET. Lad bitte eine Beispieldatei hoch.
Gruß,
steve1da

wie ich schon schrieb: mit SUMMEWENNS() ...
23.03.2015 09:45:38
neopa
Hallo Juri,
... bezogen auf die Beispieldatei in E26: =SUMMEWENNS($C$2:$C$7;$E$2:$E$7;"*"&E$25&"*";$G$2:$G$7;$D26) und nach rechts kopierbar. Auswertungsbereich dann noch entsprechend anpassen.
Gruß Werner
.. , - ...

AW: wie ich schon schrieb: mit SUMMEWENNS() ...
23.03.2015 09:51:40
Juri
Naja ich hab vergessen zu schreiben, dass die Beispieldatei stark gekürzt ist... normalerweise wäre sie 1,3 MB groß und es gabe viel mehr Zeilen... Außerdem muss das sich auch automatisch aktualisieren können X: Tut mir ehrlich Leid, aber ich bin gerade derbe hilflos...

Anzeige
die Dateigröße sagt wenig aus...
23.03.2015 10:00:33
neopa
Hallo Juri,
... entscheidend ist die Angabe des auszuwertenden Bereiches. Angenommen der geht bis Zeile Nr. 99999, dann ersetze in der Formel die 7 durch die 99999. Dann steht jedoch die Beispielliste D25:H37 wo anders. Deshalb musst Du dann auch noch den Formelteil "*"&E$25&"*" entsprechend anpassen. Die Formel kannst Du danach sowohl nach rechts als auch nach unten kopieren.
Gruß Werner
.. , - ...

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:19:33
Juri
Ich weiß nicht... Es will einfach nicht... Es soll ja einfach so wie die Tabelle darüber aussehen, nur, dass das für die 3 Sachen geteilt ist im Monat...

Anzeige
AW: die Dateigröße sagt wenig aus...
23.03.2015 10:22:06
SF
Hola,
"es will einfach nicht" ist nicht grad zielführend.
Was du möchtest, wissen wir. Woran es scheitert, leider nicht.
Gruß,
steve1da

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:29:40
Juri
Der jetzige Fehler ist, dass ich das mit dem Bereich überarbeitet habe indem ich halt die 7 mit der 9999 ersetzt habe aber trotzdem wird 0 angezeigt, egal ob ETG ETB oder SET gemeint wird...

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:31:26
SF
Hola,
zeig das mal bitte anhand einer neuen Beispieldatei.
Gruß,
steve1da

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:34:59
Juri
Hier findest du das andere Beispiel mit der Gesamten Seite

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:38:23
SF
Hola,
E25 und D26 solltest du natürlich auch anpassen. Und warum muss diese Übersicht mitten in den Bereich? Rechts daneben ab z.B. Spalte S und du bekommst keine Zirkelbezugswarnung.
Gruß,
steve1da

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:43:49
Juri
Leider kommt immer noch 0 raus, obwohl ich jetzt e25 und d26 jeweils angepasst habe, oder wie genau soll ich die denn anpassen?
Der Platz ist willkürlich, der sollte nur unter die allgemeine Tabelle, weil sie sich immer aktualisieren sollte

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:46:30
SF
Hola,
mühselig das ganze - Du hast sie angepasst, schreibst nicht wie, fragst aber wie du sie anpassen sollst.
=SUMMEWENNS($C$2:$C2000;$E$2:$E$2000;"*"&E$2129&"*";$G$2:$G$2000;$D2115)
Da deine Abfrage mitten drin steht im Bereich, der in den Formeln definiert ist, gibts Zirkelbezug - das ergibt 0.
Gruß,
steve1da

Anzeige
AW: die Dateigröße sagt wenig aus...
23.03.2015 10:52:10
Juri
Ich hab leider an der Tabelle gar nichts gemacht, außer sie nur bekommen und meine Excel-Fähigkeiten sind auch gleich Null^^ Die Abfrage muss leider darunter stattfinden, weil der obere Bereich aktualisiert werden soll... Ich weiß ist echt dämlich gelöst, aber naja... Mit welche Werten, sollte ich die bearbeiten, dass sie auch für die anderen Monate verfügbar ist, weil ich hab das eben runter gezogen aber da wird nur der Fehler #WERT! ausgegeben...

erst richtig lesen, dann auch nachdenken ...
23.03.2015 10:58:32
neopa
Hallo Juri,
... und nicht sofort nach Hilfe rufen wie Du es hier nun die ganze Zeit schon tust.
Hier mal, wie man Dein gewünschtes auch auswerten kann (entferne aber vorher Deine Auswertungsversuche unterhalb Deines Datenbereiches !)
2014 MB Jan+Feb

 TUVW
1 ETBETGSET
2187706,82228631,384353,18
3266339,7295030,544552,41
4357433,82141581,411285,36

Formeln der Tabelle
ZelleFormel
U2=SUMMEWENNS($C$2:$C$9999;$E$2:$E$9999;"*"&U$1&"*";$G$2:$G$9999;$T2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Anzeige
so kommen wir nicht wirklich weiter ..
23.03.2015 10:31:45
neopa
Hallo Juri,
... hast Du wirklich meine Hinweise von vorhin komplett beachtet?
Gruß Werner
.. , - ...

AW: die Dateigröße sagt wenig aus...
23.03.2015 10:19:39
Juri
Ich weiß nicht... Es will einfach nicht... Es soll ja einfach so wie die Tabelle darüber aussehen, nur, dass das für die 3 Sachen geteilt ist im Monat...

wo steht was ?
23.03.2015 09:09:05
WF
Hi,
in der Formel ist das Suchkriterim in D2115
Dann schreibst Du: "und in Zeile E steht ein Text ..."
Wonach soll (zusätzlich oder nur) gesucht werden ?
WF

AW: wo steht was ?
23.03.2015 09:13:02
Juri
Ich sollte noch mal im Text, oder Artikel Namen: nach ETG ETB und SET filtern...

AW: SUMMEWENN Nach Textteil zusätzlich filtern
23.03.2015 11:27:32
Juri
Nun hat es tatsächlich funktioniert.... Riesen Dank an euch alle :) und tut mir Leid für die aufwendige Arbeit...
Anzeige

338 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige