Kleinster Wert aus Liste, nebenstehende Zellen

Bild

Betrifft: Kleinster Wert aus Liste, nebenstehende Zellen
von: Robin
Geschrieben am: 20.04.2015 12:30:47

Hallo liebe Excelprofis,
ich bin nun schon lange stiller Mitleser in eurem Forum und habe mich jetzt letztendlich entschlossen, mich doch anzumelden, da ich leider einfach nichtmehr weiter weiß.
Zu meinem Problem:
Ich habe in Excel in Spalte A eine Liste von Abkürzungen, welche auch doppelt oder mehrfach vorkommen können. In den Spalten B bis H sind zugehörige Werte zu diesen Abkürzungen (je eine Zeile gehört zueinander). Wenn nun eine Abkürzung aus Spalte A mehrfach vorliegt, dann möchte ich den jeweils kleinsten Wert (aus Spalte C) dieser mehrfachen Abkürzung angezeigt bekommen, und dazu alle Werte, die in der selben Zeile stehen, in der auch der niedrigste Wert steht.
Anfangs brauchte ich nur den jeweils kleinsten Wert und konnte dies mit Matrixformeln lösen, die mir aber nun bei den restlichen Spalten nicht weiterhelfen.
Spalte H:{=WENNFEHLER(INDEX($C$2:$C$38;KGRÖSSTE(($A$2:$A$38=$A2)*(ZEILE($A$2:$A$38)-1);ZÄHLENWENN($A$2:$A$38;$A2)+1-SPALTE(A2)));"")}
Spalte I:{=WENNFEHLER(INDEX($C$2:$C$38;KGRÖSSTE(($A$2:$A$38=$A2)*(ZEILE($A$2:$A$38)-1);ZÄHLENWENN($A$2:$A$38;$A2)+1-SPALTE(B2)));"")}
Spalte J:{=WENNFEHLER(INDEX($C$2:$C$38;KGRÖSSTE(($A$2:$A$38=$A2)*(ZEILE($A$2:$A$38)-1);ZÄHLENWENN($A$2:$A$38;$A2)+1-SPALTE(C2)));"")}
Spalte K:{=WENNFEHLER(INDEX($C$2:$C$38;KGRÖSSTE(($A$2:$A$38=$A2)*(ZEILE($A$2:$A$38)-1);ZÄHLENWENN($A$2:$A$38;$A2)+1-SPALTE(G2)));"")}
Spalte L:{=WENNFEHLER(INDEX($C$2:$C$38;KGRÖSSTE(($A$2:$A$38=$A2)*(ZEILE($A$2:$A$38)-1);ZÄHLENWENN($A$2:$A$38;$A2)+1-SPALTE(H2)));"")}
Spalte M:{=WENN(H2:L2="";"";KKLEINSTE(H2:L2;1))}
Gerne komme ich um derlei Gebilde herum, da ich diese selbst aus dem Internet gesucht und bis heute die Funktion nicht ganz nachvollziehen kann.
Mit einer einfachen Sortierung komme ich leider nicht weiter, da die Werte in den Spalten A bis G sich ständig ändern und alles ohne das Zutun eines Benutzers wie oben beschrieben "sortiert" werden soll.
Wenn das ganze mit Excel zu umständlich ist, geht selbstverständlich auch VBA.
Vielen Dank im Voraus,
Robin

Bild

Betrifft: AW: Kleinster Wert aus Liste, nebenstehende Zellen
von: Hajo_Zi
Geschrieben am: 20.04.2015 13:00:42
Hallo Robin,
Du hast Extra keine Datei verlinkt, da Du die Lösung selber an Deine Bedingungen anpassen wolltest. Viel Erfolg, ich bin dann raus da Lösung erstellt.

Tabelle1

 HIJKLMNO
39250,523456

verwendete Formeln
Zelle Formel Bereich N/A
H39:O39{=WENNFEHLER(INDEX($A$2:$H$38;VERGLEICH(MIN(WENN($A$2:$A$38=$A$2;$C$2:$C$38));$C$2:$C$38;0);SPALTE()-7);"")}$H$39 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.26 einschl. 64 Bit




Bild

Betrifft: AW: Kleinster Wert aus Liste, nebenstehende Zellen
von: Robin
Geschrieben am: 20.04.2015 13:27:11
Vielen Dank Hajo_Zi für die prompte Antwort. Die Formel lässt sich wunderbar anwenden und liefert genau das gesuchte.
Liebe Grüße,
Robin

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kleinster Wert aus Liste, nebenstehende Zellen"