Suchen nebenstehende Werte addieren

Bild

Betrifft: Suchen nebenstehende Werte addieren
von: SW
Geschrieben am: 21.04.2015 12:34:30

Hallo!
Eine Tabelle wie folgt (stark vereinfacht - Original unheimlich breit und lang) stellt mich vor Herausforderungen:
______ A ______ B ______ C ______ D ______ E ______ F ______...
1 _ Klaus _____ 35 _____ 17 ___ Herbert __ 37 _____ 12 ______
2 _ Max ______ 28 ______ 8 ___ Klaus ____ 35 ______ 4 ______
3 _ Hans _____ 28 _____ 16 ___ Hans _____ 28 ______ 4 ______
.
.
. Klaus ?Summe?
Ich möchte nun eine Formel (?Summe?) die mir die Summe aller Zellen, die zwei Zellen rechts von einer Zelle mit dem Inhalt "Klaus" stehen ausgibt.
Im Oberen Beispiel müsste also der Bereich der Zeilen 1 bis 3 durchsucht werden und dann die Zellen C1 und F2 addiert werden. Das Ergebnis müsste also 21 lauten.
Mit SUMMEWENN komm ich nicht weiter, weil ich sonst alle Spaltenbereiche einzeln angeben muss. Dann lässt sich die Tabelle aber nicht bei Bedarf einfach nach rechts erweitern.
Irgendwelche Vorschläge?
Viele Grüße
SW

Bild

Betrifft: Das geht über Bereichs-Shift
von: lupo1
Geschrieben am: 21.04.2015 13:00:39
=SUMMENPRODUKT(--(A1:D3="Klaus");C1:F3)

Bild

Betrifft: AW: Das geht über Bereichs-Shift
von: SW
Geschrieben am: 21.04.2015 13:35:54
Super, das funktioniert.
DANKE

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suchen nebenstehende Werte addieren"