Summenprodukt in Spalten und Zeilen?

Bild

Betrifft: Summenprodukt in Spalten und Zeilen?
von: Heinz
Geschrieben am: 18.05.2015 13:55:03

Hallo Liebe Excellenten,
ich habe folgende Aufgabenstellung.
Eine Große Tabelle mit Artikeln (Bier).
In den ersten Spalte stehen pro Artikel Bezeichnungen
wie Größe, Preis, Verpackung (Dose oder Flasche) usw.
In der Spalten mit den Werte gibt es für jedes Produkt eine
Werte-Spalte, also z.B. Spalten für Becks_Gold_Pils; Radeberger_Radler;
Paulaner_Weissbier; Becks_Radler; Becks_Radler_Alkoholfrei; ....
Ich habe in einer der Zeilen über den Spalten mit den Produktwerten
jeweils nur die Marke extrahiert, also Becks, Radeberger, Paulaner, usw.
Ich bräuchte jetzt eine Formel, die mir Sinngemäß folgendes liefert:
Wenn in Spalte1=0,33 und in Spalte2=1,99 und in Spalte3="Dose", dann summiere
mir alle Werte in den Spalten, in denen darüber die Marke Becks steht (in meinem
kleinen Beispiel wären das 3 Spalten).
Sortieren geht leider nicht, weil ich die Tabelle so bekomme und auch wieder
weitergeben muss.
Ideal wäre eine Summenprodukt Formel, aber ich bin natürlich mit jeder
Lösung (außer VBA) zufrieden.
Ich freue mich auf Eure Lösungen und wünsche allen einen
schönen Tag.
Heinz

Bild

Betrifft: Wieso nicht Pivottabelle? (owT)
von: EtoPHG
Geschrieben am: 18.05.2015 14:01:30


Bild

Betrifft: AW: Summenprodukt in Spalten und Zeilen?
von: ransi
Geschrieben am: 18.05.2015 14:03:07
Hallo Heinz,
Ich hab ein Problem wir anhand deiner Beschreibung ne Testumgebung zu basteln.
Lade doch mal ne kleine Beispieltabelle hoch.
ransi

Bild

Betrifft: Summenprodukt in Spalten und Zeilen?
von: Heinz
Geschrieben am: 18.05.2015 14:31:39
Hab ich mal gemacht,
https://www.herber.de/bbs/user/97699.xlsx
Übrigens: Pivot ist (wahrscheinlich aufgrund meiner Kenntnisse)
nicht so flexibel.
Heinz

Bild

Betrifft: AW: Summenprodukt in Spalten und Zeilen?
von: EtoPHG
Geschrieben am: 18.05.2015 14:55:46
Hallo Heinz,
Die Formeln für:
M11...Mx: =SUMMEWENN($F$9:$L$9;"Becks*";F11:L11)
N11...Nx: =WENN(B11="Dose";SUMMEWENN($F$9:$L$9;"Becks*";F11:L11);0)
O11...Ox: =WENN(A11=0,33;SUMMEWENN($F$9:$L$9;"Becks*";F11:L11);0)
Gruess Hansueli

Bild

Betrifft: AW: Summenprodukt in Spalten und Zeilen?
von: Heinz
Geschrieben am: 18.05.2015 15:49:22
Hallo Hans,
Super Ansatz;
Ich habe gerade versucht, statt der Summwenn eine Summewenns zu verwenden,
weil ich ggf. noch eine zweite "Zeilenbedingung" einbauen musss, also neben
der Marke in Zeile 3 auch noch das Segment in Zeile 4.
Dein Weg hat mich da sehr geholfen.
Danke Dir (und allen anderen Foren-TN)
Heinz

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt in Spalten und Zeilen?"