möglichst automatisch (A1*A5)+(B1*B5)+...

Bild

Betrifft: möglichst automatisch (A1*A5)+(B1*B5)+...
von: Fabio
Geschrieben am: 17.06.2015 14:24:28

Hallo zusammen
Ich muss mehrere hundert Positionen folgendermassen berechnen (Excel 2010):
(Anz Artikel A * Einstandspreis Artikel A)+((Anz Artikel B * Einstandspreis Artikel B) usw = Gesamtpreis
Muss ich dazu eine elend lange Formel von Hand schreiben, oder lässt sich dies mit einer Formel / Funktion etwas einfacher berechnen?
Vielen Dank für eure Hilfe

Bild

Betrifft: AW: möglichst automatisch (A1*A5)+(B1*B5)+...
von: Rudi Maintaire
Geschrieben am: 17.06.2015 14:28:26
Hallo,
ganz einfach
=Summenprodukt(A1:Z1;A5:Z5)
Gruß
Rudi

Bild

Betrifft: AW: möglichst automatisch (A1*A5)+(B1*B5)+...
von: Daniel
Geschrieben am: 17.06.2015 14:28:48
Hi
kommt jetzt darauf an, wie und wo deine Werte stehen.
wenn ich mal vom Bertreff ausgehe, dann steht die Anzahl in Zeile 1 und der Einzelpreis in Zeile 5, die Artikel sind von Spalte A bis Spalte X (anpassen) gelistet:
=SummenProdukt(A1:X1;A5:X5)
Gruß Daniel

Bild

Betrifft: AW: möglichst automatisch (A1*A5)+(B1*B5)+...
von: Hajo_Zi
Geschrieben am: 17.06.2015 14:37:18

Tabelle2

 ABCDEFGH
111121314151617 
5100101102103104105106 
6110012121326144215601680180210122
7       10122

verwendete Formeln
Zelle Formel Bereich N/A
B1:G1,B5:G5=A1+1  
A6:G6=A1*A5  
H6=SUMME(A6:G6)  
H7{=SUMME(A1:G1*A5:G5)}$H$7 
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.04 einschl. 64 Bit




Bild

Betrifft: AW: möglichst automatisch (A1*A5)+(B1*B5)+...
von: Fabio
Geschrieben am: 18.06.2015 08:23:54
Hallo zusammen
Vielen Dank für eure Rückmeldungen. Hab's mit Hajo_Zis Matrixformel problemlos geschafft. Bin mir aber sicher, dass auch die zwei anderen Vorschläge zum Ziel geführt hätten.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "möglichst automatisch (A1*A5)+(B1*B5)+..."