Werte durchzählen

Bild

Betrifft: Werte durchzählen
von: Jan
Geschrieben am: 17.06.2015 16:18:21

Hallo, ich habe verschiedene Tage und verschiedene Namen in verschiedenen Tabellenblättern.Pro Name und Tag werden Arbeitsstunden erfasst. Die Namen können an den Tagen unterschiedlich sein und am Ende soll aber in einer Wochenliste die Anzahl der Stunden in Summe stehen, die je Name erbracht wurden. Die Namensliste ist fest und muss nicht automatisch ermittelt werden. ich brauche nur die Zuordnung der Stunden in die Woche. Alles in einem Blatt :)
Hier mal die Datei:
https://www.herber.de/bbs/user/98209.xlsx
Habt ihr eine Idee wie ich das machen kann?

Bild

Betrifft: AW: Werte durchzählen
von: SF
Geschrieben am: 17.06.2015 16:30:11
Hola,
das ist doch aber bestimmt nicht der Originalaufbau der Tabelle, oder?
Übrigens hast du doch schon die Formel für Montag, also einfach +Summewenn(....) für Dienstag, für Mittwoch, etc.
Gruß,
steve1da

Bild

Betrifft: AW: Werte durchzählen
von: selli
Geschrieben am: 17.06.2015 16:34:39
hallo jan,
so wie deine datei aufgebaut ist wirst du daran nicht viel freude haben.
um eine vernünftige auswertung zu bekommen bietet es sich an eine datenbank in einem tabellenblatt tabellarisch aufzubauen.
dann kannst du mittels einer pivottable die werte ziehen, die du brauchst.
fazit: 1 blatt für alle daten und 1 blatt für die auswertung
gruß
selli

Bild

Betrifft: AW: Werte durchzählen
von: UweD
Geschrieben am: 17.06.2015 16:39:27
Hallo
so ???

Woche

 AB
1Woche
2hans 5
3frank1
4ulla4
5bernd5
6Thomas2
7Heidi1
8ulla4

 verbundene Zellen 
A1:B1

verwendete Formeln
Zelle Formel Bereich N/A
B2=SUMMENPRODUKT(SUMMEWENN(INDIREKT({"Mo";"Di";"Mi"}&"!A:A");A2;INDIREKT({"Mo";"Di";"Mi"}&"!B:B")))  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.03 einschl. 64 Bit


Gruß UweD

Bild

Betrifft: AW: Werte durchzählen
von: Kenny
Geschrieben am: 17.06.2015 16:42:39
Hallo,
Hätte hier eine VBA Lösung :)


Sub Summe_Namen()
Set wa = Worksheets("Woche")
zähler = 1
For zeile = 2 To wa.UsedRange.Rows.Count
    Name = wa.Cells(zeile, 1)
    Worksheets(1).Activate
    zähler = 1
    summe = 0
        Do Until ActiveWorkbook.ActiveSheet.Name = "Woche"
            Worksheets(zähler).Activate
            If IsError(Application.VLookup(Name, Worksheets(zähler).Range("A2:B" & Worksheets(zä _
hler).UsedRange.Rows.Count), 2, False)) = False Then
                    summe = summe + Application.VLookup(Name, Worksheets(zähler).Range("A2:B" &  _
Worksheets(zähler).UsedRange.Rows.Count), 2, False)
            End If
            zähler = zähler + 1
        Loop
    wa.Cells(zeile, 2) = summe
Next
End Sub


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Sehr viele Zellen auswählen mit VBA"